summaryrefslogtreecommitdiff
path: root/app-shells/rc/rc-1.7.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/rc/rc-1.7.4-r2.ebuild')
-rw-r--r--app-shells/rc/rc-1.7.4-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/rc/rc-1.7.4-r2.ebuild b/app-shells/rc/rc-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a38be60805e8
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="sys-libs/ncurses:=
+ readline? ( sys-libs/readline:= )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=edit"
+
+ econf "${myconf}"
+}
+
+src_install() {
+ into /usr
+ newbin "${PN}" "${PN}sh"
+ newman "${PN}.1" "${PN}sh.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! grep -q '^/usr/bin/rcsh$' "${EROOT}"/etc/shells ; then
+ ebegin "Updating /etc/shells"
+ echo "/usr/bin/rcsh" >> "${EROOT}"/etc/shells
+ eend $?
+ fi
+}