summaryrefslogtreecommitdiff
path: root/app-shells/starship/files/starship-1.12.0-no-old-time.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/starship/files/starship-1.12.0-no-old-time.patch')
-rw-r--r--app-shells/starship/files/starship-1.12.0-no-old-time.patch109
1 files changed, 109 insertions, 0 deletions
diff --git a/app-shells/starship/files/starship-1.12.0-no-old-time.patch b/app-shells/starship/files/starship-1.12.0-no-old-time.patch
new file mode 100644
index 000000000000..90fb09c027dd
--- /dev/null
+++ b/app-shells/starship/files/starship-1.12.0-no-old-time.patch
@@ -0,0 +1,109 @@
+From 1230165a935789b45f7ecabf6ecb1edc5fd77d8d Mon Sep 17 00:00:00 2001
+From: Alexey Zapparov <alexey@zapparov.com>
+Date: Wed, 21 Dec 2022 22:54:23 +0100
+Subject: [PATCH] Remove time-0.1.x dependency
+
+Bug: https://bugs.gentoo.org/864034
+See: RUSTSEC-2020-0071 <https://rustsec.org/advisories/RUSTSEC-2020-0071>
+See: Upstream Fix Proposal <https://github.com/starship/starship/pull/4750>
+Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
+---
+ Cargo.lock | 26 ++++----------------------
+ Cargo.toml | 2 +-
+ 2 files changed, 5 insertions(+), 23 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index c5b4c42c..41ddabf9 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -309,7 +309,6 @@ dependencies = [
+ "js-sys",
+ "num-integer",
+ "num-traits",
+- "time 0.1.44",
+ "wasm-bindgen",
+ "winapi",
+ ]
+@@ -1001,7 +1000,7 @@ dependencies = [
+ "bstr",
+ "itoa",
+ "thiserror",
+- "time 0.3.14",
++ "time",
+ ]
+
+ [[package]]
+@@ -1660,7 +1659,7 @@ dependencies = [
+ "dirs-next",
+ "objc-foundation",
+ "objc_id",
+- "time 0.3.14",
++ "time",
+ ]
+
+ [[package]]
+@@ -2662,7 +2661,7 @@ checksum = "8bf8e33626554dd9027d240a3b91d73be43054c0f9ef645cdf0483b6ebe822fa"
+ dependencies = [
+ "const_format",
+ "is_debug",
+- "time 0.3.14",
++ "time",
+ ]
+
+ [[package]]
+@@ -2869,7 +2868,7 @@ dependencies = [
+ "lazy_static",
+ "libc",
+ "nom 7.1.1",
+- "time 0.3.14",
++ "time",
+ "winapi",
+ ]
+
+@@ -2997,17 +2996,6 @@ dependencies = [
+ "syn",
+ ]
+
+-[[package]]
+-name = "time"
+-version = "0.1.44"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "6db9e6914ab8b1ae1c260a4ae7a49b6c5611b40328a735b21862567685e73255"
+-dependencies = [
+- "libc",
+- "wasi 0.10.0+wasi-snapshot-preview1",
+- "winapi",
+-]
+-
+ [[package]]
+ name = "time"
+ version = "0.3.14"
+@@ -3280,12 +3268,6 @@ version = "0.9.0+wasi-snapshot-preview1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "cccddf32554fecc6acb585f82a32a72e28b48f8c4c1883ddfeeeaa96f7d8e519"
+
+-[[package]]
+-name = "wasi"
+-version = "0.10.0+wasi-snapshot-preview1"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "1a143597ca7c7793eff794def352d41792a93c481eb1042423ff7ff72ba2c31f"
+-
+ [[package]]
+ name = "wasi"
+ version = "0.11.0+wasi-snapshot-preview1"
+diff --git a/Cargo.toml b/Cargo.toml
+index 97b393f3..6c9ff8ef 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -42,7 +42,7 @@ git-repository-max-perf = ["git-features/zlib-ng", "git-repository/fast-sha1"]
+ git-repository-faster = ["git-features/zlib-stock", "git-repository/fast-sha1"]
+
+ [dependencies]
+-chrono = { version = "0.4.23", features = ["clock", "std"] }
++chrono = { version = "0.4.23", default-features = false, features = ["clock", "std", "wasmbind"] }
+ clap = { version = "4.0.29", features = ["derive", "cargo", "unicode"] }
+ clap_complete = "4.0.6"
+ dirs-next = "2.0.0"
+--
+2.38.2
+