summaryrefslogtreecommitdiff
path: root/app-text/cherrytree/cherrytree-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cherrytree/cherrytree-1.2.0.ebuild')
-rw-r--r--app-text/cherrytree/cherrytree-1.2.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-text/cherrytree/cherrytree-1.2.0.ebuild b/app-text/cherrytree/cherrytree-1.2.0.ebuild
index 9c67de85be38..d2e8464e00c5 100644
--- a/app-text/cherrytree/cherrytree-1.2.0.ebuild
+++ b/app-text/cherrytree/cherrytree-1.2.0.ebuild
@@ -68,10 +68,15 @@ src_configure() {
-DUSE_NLS=$(usex nls)
-DBUILD_TESTING=$(usex test)
-DUSE_SHARED_FMT_SPDLOG=ON
- -DAUTO_RUN_TESTING=OFF
-DUSE_SHARED_GTEST_GMOCK=$(usex test)
)
+ if use test; then
+ mycmakeargs+=(
+ -DAUTO_RUN_TESTING=OFF
+ )
+ fi
+
cmake_src_configure
}