summaryrefslogtreecommitdiff
path: root/app-text/cook
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cook')
-rw-r--r--app-text/cook/Manifest3
-rw-r--r--app-text/cook/cook-1.0.2-r1.ebuild45
-rw-r--r--app-text/cook/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/app-text/cook/Manifest b/app-text/cook/Manifest
new file mode 100644
index 000000000000..3edc6186a43b
--- /dev/null
+++ b/app-text/cook/Manifest
@@ -0,0 +1,3 @@
+DIST cook-1.0.2.tar.gz 139428 BLAKE2B c3f1a3e753a7de14fce4f357af64f99af5e0a515988bb2aef40b79a0cc70dcba4bb585c1fa31e0da1d235fc1c363e9693338756f2bd784898a7dc63944b9ed51 SHA512 6941d3541a6cccc18fcbf14128e0593556148d40f74715b0da943455a223099406d632466137fabef27a2083b582701df92666a1ad6e6a04f5d2d3dc0b62e1a1
+EBUILD cook-1.0.2-r1.ebuild 1131 BLAKE2B 054ff9116919a34d481cf45d4ac8a27dba153265e9debbfaf0e31803554015aec4ea39b6f5a66e7f9b0d51ebe23d01c74a30b320669bd645414336c993563c6b SHA512 0bc16805bb07f199d2885c06481343efea93647a57e50b9298437f202bcdc208ff5b8169cd8f109e7d84846cce8af34b409ee528e561ab91398af0a694212ecb
+MISC metadata.xml 241 BLAKE2B 6f92bb59126251d9e6b2cae4fa0a43926317c6c133dd882e845fe0b693238311241463d8de465e36ff2e90c7c25ea35309e3bc5b0c20a32153965ce0b626a1da SHA512 36edaae333e04297f6f6357cbcaaf6360580a83e20ec3af8b09c1010601e47c29c45b6eec5347cb90f8fc1fecdffeb1074d3ee55dda78c29026210ea58a7264c
diff --git a/app-text/cook/cook-1.0.2-r1.ebuild b/app-text/cook/cook-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..cfa071431faf
--- /dev/null
+++ b/app-text/cook/cook-1.0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit toolchain-funcs
+
+DESCRIPTION="Embedded language which can be used as a macro preprocessor"
+HOMEPAGE="http://cook.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cook/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ use prefix || EPREFIX=
+
+ dodoc README doc/cook.txt doc/cook.html || die "dodoc failed"
+
+ insinto /usr/share/doc/${PF}/example
+ doins test/pcb.dbdef test/pcb.dg test/pcbprol.ps test/tempsens.pcb || die "doins failed"
+
+ newbin src/cook cookproc || die "newbin failed"
+
+ cat > "${T}"/README.Gentoo <<EOF
+NOTICE:
+
+ ${EPREFIX}/usr/bin/cook has been renamed to ${EPREFIX}/usr/bin/cookproc in Gentoo
+
+ -- Karl Trygve Kalleberg <karltk@gentoo.org>
+EOF
+ dodoc "${T}"/README.Gentoo || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn "${EPREFIX}/usr/bin/cook has been renamed to ${EPREFIX}/usr/bin/cookproc"
+}
diff --git a/app-text/cook/metadata.xml b/app-text/cook/metadata.xml
new file mode 100644
index 000000000000..7e1c91980a55
--- /dev/null
+++ b/app-text/cook/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">cook</remote-id>
+ </upstream>
+</pkgmetadata>