summaryrefslogtreecommitdiff
path: root/app-text/html2text/html2text-1.3.2a-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/html2text/html2text-1.3.2a-r1.ebuild')
-rw-r--r--app-text/html2text/html2text-1.3.2a-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/html2text/html2text-1.3.2a-r1.ebuild b/app-text/html2text/html2text-1.3.2a-r1.ebuild
new file mode 100644
index 000000000000..8b1dad0a9b36
--- /dev/null
+++ b/app-text/html2text/html2text-1.3.2a-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A HTML to text converter"
+HOMEPAGE="http://www.mbayer.de/html2text/"
+SRC_URI="http://www.mbayer.de/html2text/downloads/${P}.tar.gz
+ http://www.mbayer.de/html2text/downloads/patch-utf8-${P}.diff
+ http://www.mbayer.de/html2text/downloads/patch-amd64-${P}.diff
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ tc-export CXX
+ epatch \
+ "${FILESDIR}/${P}-compiler.patch" \
+ "${FILESDIR}/${P}-urlistream-get.patch" \
+ "${DISTDIR}/patch-utf8-${P}.diff" \
+ "${DISTDIR}/patch-amd64-${P}.diff"
+ epatch_user
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" DEBUG="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin html2text
+ doman html2text.1.gz html2textrc.5.gz
+ dodoc CHANGES CREDITS KNOWN_BUGS README TODO
+}