summaryrefslogtreecommitdiff
path: root/app-text/krop/krop-0.4.13.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/krop/krop-0.4.13.5.ebuild')
-rw-r--r--app-text/krop/krop-0.4.13.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/krop/krop-0.4.13.5.ebuild b/app-text/krop/krop-0.4.13.5.ebuild
new file mode 100644
index 000000000000..23966dc8cf43
--- /dev/null
+++ b/app-text/krop/krop-0.4.13.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+#SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~huettel/distfiles/${P}.tar.gz"
+# this is a snapshot of the qt5 branch
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}