summaryrefslogtreecommitdiff
path: root/app-text/libebook/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libebook/files')
-rw-r--r--app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch10
-rw-r--r--app-text/libebook/files/libebook-0.1.2-tests.patch27
-rw-r--r--app-text/libebook/files/libebook-0.1.3-icu-68.patch27
3 files changed, 27 insertions, 37 deletions
diff --git a/app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch b/app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch
deleted file mode 100644
index 9869b308c73c..000000000000
--- a/app-text/libebook/files/libebook-0.1.2-boost-1.59-makefile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/lib/Makefile.am
-+++ b/src/lib/Makefile.am
-@@ -64,6 +64,7 @@
- libe_book_@EBOOK_MAJOR_VERSION@_@EBOOK_MINOR_VERSION@_la_SOURCES = \
- EBOOKDocument.cpp
-
-+libe_book_internal_la_CPPFLAGS = -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED
- libe_book_internal_la_SOURCES = \
- EBOOKBitStream.cpp \
- EBOOKBitStream.h \
diff --git a/app-text/libebook/files/libebook-0.1.2-tests.patch b/app-text/libebook/files/libebook-0.1.2-tests.patch
deleted file mode 100644
index 624051a757aa..000000000000
--- a/app-text/libebook/files/libebook-0.1.2-tests.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 263d95ce191421a51d4b2d088297700032a8987b Mon Sep 17 00:00:00 2001
-From: eroen <eroen@occam.eroen.eu>
-Date: Mon, 19 Dec 2016 19:53:15 +0100
-Subject: [PATCH] Check for librevenge-stream if tests are enabled
-
-X-Gentoo-Bug: 603098
-X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=603098
----
- configure.ac | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 6e00ed5..ecbd14b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -357,6 +357,8 @@ AS_IF([test "x$with_tools" = "xyes"],[
- PKG_CHECK_MODULES([REVENGE_GENERATORS],[
- librevenge-generators-0.0
- ])
-+])
-+AS_IF([test "x$with_tools" = "xyes" || test "x$enable_tests" = "xyes"],[
- PKG_CHECK_MODULES([REVENGE_STREAM],[
- librevenge-stream-0.0
- ])
---
-2.11.0
-
diff --git a/app-text/libebook/files/libebook-0.1.3-icu-68.patch b/app-text/libebook/files/libebook-0.1.3-icu-68.patch
new file mode 100644
index 000000000000..964b8b7e195d
--- /dev/null
+++ b/app-text/libebook/files/libebook-0.1.3-icu-68.patch
@@ -0,0 +1,27 @@
+From 9ea3b4c2552770b66b83d44b6e6ccdd338296316 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 30 Oct 2020 10:52:10 +0100
+Subject: [PATCH] Fix build with icu-68.0
+
+icu-68.1 removed public macro definitions for TRUE and FALSE
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/lib/EBOOKCharsetConverter.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lib/EBOOKCharsetConverter.cpp b/src/lib/EBOOKCharsetConverter.cpp
+index 0d85fa3..c9f8be0 100644
+--- a/src/lib/EBOOKCharsetConverter.cpp
++++ b/src/lib/EBOOKCharsetConverter.cpp
+@@ -124,7 +124,7 @@ bool EBOOKCharsetConverter::convertBytes(const char *const in, const unsigned le
+ m_converterToUTF8.get(), m_converterToUnicode.get(),
+ &outText, outText + out.size(), &inText, inText + length,
+ nullptr, nullptr, nullptr, nullptr,
+- TRUE, TRUE, &status)
++ true, true, &status)
+ ;
+ if (status==U_BUFFER_OVERFLOW_ERROR)
+ {
+--
+2.29.2