summaryrefslogtreecommitdiff
path: root/app-text/libqxp/libqxp-0.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libqxp/libqxp-0.0.2.ebuild')
-rw-r--r--app-text/libqxp/libqxp-0.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/libqxp/libqxp-0.0.2.ebuild b/app-text/libqxp/libqxp-0.0.2.ebuild
new file mode 100644
index 000000000000..f1095915cd1f
--- /dev/null
+++ b/app-text/libqxp/libqxp-0.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library parsing QuarkXpress documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug doc test tools"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/icu:=
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-weffc
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable test tests)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}