summaryrefslogtreecommitdiff
path: root/app-text/libwps/libwps-0.4.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libwps/libwps-0.4.11.ebuild')
-rw-r--r--app-text/libwps/libwps-0.4.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/libwps/libwps-0.4.11.ebuild b/app-text/libwps/libwps-0.4.11.ebuild
new file mode 100644
index 000000000000..ea494a549900
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug doc static-libs tools"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}