summaryrefslogtreecommitdiff
path: root/app-text/lout
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/lout')
-rw-r--r--app-text/lout/Manifest4
-rw-r--r--app-text/lout/files/lout-3.38-makefile.patch33
-rw-r--r--app-text/lout/lout-3.40.ebuild85
-rw-r--r--app-text/lout/metadata.xml8
4 files changed, 130 insertions, 0 deletions
diff --git a/app-text/lout/Manifest b/app-text/lout/Manifest
new file mode 100644
index 000000000000..3749840175eb
--- /dev/null
+++ b/app-text/lout/Manifest
@@ -0,0 +1,4 @@
+AUX lout-3.38-makefile.patch 715 BLAKE2B d2d72e707691a5fe09e152de7c113a821e524c2f67a37e1b6ad1d064e8ab499bc32004967bf226a225ce7fc41e808f4758f9f50dcfd6254b51c0500a53d9d1bd SHA512 17fbc465143bec59ca1bb410aa3b4e376ce2fc4e65a15747f72104db9387ba9429ce21f83e2b64224ed8b856c42b68df4bf27e2c9df9ed4d9bae872b126967bc
+DIST lout-3.40.tar.gz 2172651 BLAKE2B 0bf2ee498d6fbb91e353d46fe1f7f0f44053be174df901b08ee630f0b4935e19c056a50e2eda4d07ab69aac6d7bf738b42277bb37060e967db73ace6a51029af SHA512 adffbb44b9328f0d64b1c8f08fe0217307b1cca870827ca54e0aaae5a2258f519e3e6f0adc715ba6d192dd731ab26c2cc86aa8611d991d5665503842e599c061
+EBUILD lout-3.40.ebuild 2046 BLAKE2B 24a403a7b363bf9a43a91a1cf1696467131eca94fd6371cd13ba534b326af7e8b11b03ccea54031b48fddf5b5beeddaf8abad6d7a84d9831c64afb14ccb542ee SHA512 31ffe212dfa3f64156ad8376c862eedf4ea568c2b3649ce92d62789820cc8bbc7f2c9778e08fc29d5bf0dea76064e6ae6caac62f7692153109fccf9dd83ffeea
+MISC metadata.xml 241 BLAKE2B e0a2a0802fa3cdf63e76215187d14bf8f7dce89bfa0a518034c19f8efc658f8c1264e0c8d27647dcb08be031828619220f457168941be3dc067a4092fbf9ff88 SHA512 a51c29d1e99be12f982724f0d4e738b509cbf9bdfa71461320386fcbd9f44431c09e78487ea246540285b39cb271d5e75da04512ef89fca87729161388aaf8e9
diff --git a/app-text/lout/files/lout-3.38-makefile.patch b/app-text/lout/files/lout-3.38-makefile.patch
new file mode 100644
index 000000000000..cb7fc66bf432
--- /dev/null
+++ b/app-text/lout/files/lout-3.38-makefile.patch
@@ -0,0 +1,33 @@
+--- lout-3.38/makefile.orig 2008-10-13 23:35:17.000000000 +0200
++++ lout-3.38/makefile 2009-09-04 16:40:00.000000000 +0200
+@@ -295,11 +295,9 @@
+ ZLIB =
+ ZLIBPATH =
+
+-CC = gcc
+-
+ RCOPY = cp -r
+
+-COPTS = -ansi -pedantic -Wall -O3
++COPTS += -ansi -pedantic -Wall
+
+ CFLAGS = -DOS_UNIX=$(OSUNIX) \
+ -DOS_DOS=$(OSDOS) \
+@@ -333,7 +331,7 @@
+ z49.o z50.o z51.o z52.o
+
+ lout: $(OBJS)
+- $(CC) -o lout $(OBJS) $(ZLIB) -lm
++ $(CC) $(COPTS) $(LDFLAGS) -o lout $(OBJS) $(ZLIB) -lm
+ chmod a+x lout
+
+ $(OBJS): externs.h
+@@ -341,7 +339,7 @@
+ externs.h:
+
+ prg2lout: prg2lout.c
+- $(CC) $(COPTS) -o prg2lout prg2lout.c
++ $(CC) $(COPTS) $(LDFLAGS) -o prg2lout prg2lout.c
+ chmod a+x prg2lout
+
+ all: lout prg2lout
diff --git a/app-text/lout/lout-3.40.ebuild b/app-text/lout/lout-3.40.ebuild
new file mode 100644
index 000000000000..e6d0cc7f1f25
--- /dev/null
+++ b/app-text/lout/lout-3.40.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+IUSE="zlib doc"
+
+DESCRIPTION="High-level language for document formatting"
+HOMEPAGE="http://savannah.nongnu.org/projects/lout"
+SRC_URI="mirror://nongnu/lout/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.38-makefile.patch"
+)
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake COPTS="${CFLAGS}" BINDIR="${EPREFIX}"/usr/bin \
+ LOUTLIBDIR="${EPREFIX}"/usr/share/lout \
+ LOUTDOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${ED}usr/bin
+ libdir=${ED}usr/share/lout
+ docdir=${ED}usr/share/doc/${PF}
+ mandir=${ED}usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${ED}"usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}
diff --git a/app-text/lout/metadata.xml b/app-text/lout/metadata.xml
new file mode 100644
index 000000000000..d87f47dba103
--- /dev/null
+++ b/app-text/lout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">lout</remote-id>
+ </upstream>
+</pkgmetadata>