summaryrefslogtreecommitdiff
path: root/app-text/mupdf
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/Manifest3
-rw-r--r--app-text/mupdf/mupdf-1.25.2-r1.ebuild174
-rw-r--r--app-text/mupdf/mupdf-1.25.2.ebuild2
3 files changed, 177 insertions, 2 deletions
diff --git a/app-text/mupdf/Manifest b/app-text/mupdf/Manifest
index fcd9ab3d376d..2ab01b3467a9 100644
--- a/app-text/mupdf/Manifest
+++ b/app-text/mupdf/Manifest
@@ -9,5 +9,6 @@ AUX mupdf-1.24.8-c23.patch 782 BLAKE2B da6da463c77cb58256327c98c9db04581c115c570
DIST mupdf-1.24.8-source.tar.gz 54039703 BLAKE2B 0fe25d9f0f01a1e387da590c28abac66309247c46c05c7c9b36c4bc911fc16adab681243c2c1d2c50ec91bb76b737022bd3faf06b0b3a803e9120829d9cae5b4 SHA512 17d8fd9fd0e176c8abd1ebc594259a0f7cf822338085ea4574451ba8ec1ac72ba8bd2d5388a1421bbfd4e91257a48d0e0766213ace0933c39d3cb8d774a3860e
DIST mupdf-1.25.2-source.tar.gz 54635699 BLAKE2B 08e4c1bd4d8f9a731b10e1368c3f4a62a9b949c4a1842f2ce297ef3a595107f63e184230c31149a6a5db9038838d891fdeb0330323afcdc0b6966bee06046288 SHA512 089bcf228a28e5f47e793d66f6355b22b531c031a6d1feb0dd07a5fee55780fda92d6cde646336ca0200869c32d523be23a8fe2232fad010b38673419c7859f2
EBUILD mupdf-1.24.8.ebuild 5016 BLAKE2B 7ad624151e5f4285eb9cd18ad5426a6ab1917f39810ff1441ce13fa1099b2d4d786582ff87e592a3e8f52514d4e758ddde921b42a37f595ddbabe3a8eaa27433 SHA512 c5bb133077d468362feca0aadb2c85dfae28976ae42da0f16480d45bb4de2b7e5a0598457d66e6f9811a7abb37ae591032396bd4921ef4d090c6d7fc781b123e
-EBUILD mupdf-1.25.2.ebuild 5018 BLAKE2B c8700639e7ed97a2eebdf21dc7a444780247a38d7c8bb3fe6363948f41fcde09520264be38e3ea971136af539ba2f788657d2fcd99894ca30bcda577fd7abe47 SHA512 02c3c235f126a2aa71a062b258b5c902d248af6ad8b65e32048b4d312f89557eb6f2f36b41366e34810b5fdafd8e855af27327f4fa3c663500cb4c0651322e2c
+EBUILD mupdf-1.25.2-r1.ebuild 5261 BLAKE2B 5a55a3e877535b31e85d32d78ed964bba85cd8476a3de7a9c7f896b5767fc5d3b48e3a01412336f10c23d6d3e4643b8bf4c9b5b5118d98bf01ac754245119290 SHA512 2ca34636e19e2649a9d9a8a405b747075a228bddb1db8d463733fd043102140978e50a9a6da3ba330e3bb2f6ac003fb1b9fa5a6e0440e1bc63367e9929a34a40
+EBUILD mupdf-1.25.2.ebuild 5017 BLAKE2B 97da2a34a20869f703b961cb8c5de377f5447c46500005f97d8fbe0f54f6e0e8c1f23e994196b94090e2472144e0c7f5e61c5c6d615bbae483ce67ad2f77a577 SHA512 f5fa098750e7fd4360e0c2d681e366f7aff48b92593ae69939cf17b57ecf6dcef52678d8c8cf6e8bcb1497d41d32ab26cfa4b9905bfc6a27d94d652378224d6c
MISC metadata.xml 516 BLAKE2B ad2fb06efd79889747566fbef91a71dcdc3452443dc6edbf077510b494b74b75a153262390c09eb625e54d6c13b63e557acdf11b0843ab35337ff581536fccb8 SHA512 d823f015eb0c9e5354845adf5296de8c52bc33c135b17fba04955ed85b6c5f2ff7c4c630fbf6010b4cd98728591a7340f30e2d6bd90573c1a9f2b3a47ae9a537
diff --git a/app-text/mupdf/mupdf-1.25.2-r1.ebuild b/app-text/mupdf/mupdf-1.25.2-r1.ebuild
new file mode 100644
index 000000000000..5ff785acd5a9
--- /dev/null
+++ b/app-text/mupdf/mupdf-1.25.2-r1.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please check upstream git regularly for relevant security-related commits
+# to backport.
+
+inherit desktop flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="A lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="https://mupdf.com/ https://git.ghostscript.com/?p=mupdf.git"
+SRC_URI="https://mupdf.com/downloads/archive/${P}-source.tar.gz"
+S="${WORKDIR}"/${P}-source
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="archive +javascript +jpeg2k opengl ssl X"
+REQUIRED_USE="opengl? ( javascript )"
+
+# Although we use the bundled, patched version of freeglut in mupdf (because of
+# bug #653298), the best way to ensure that its dependencies are present is to
+# install system's freeglut.
+RDEPEND="
+ archive? ( app-arch/libarchive )
+ dev-libs/gumbo:=
+ media-libs/freetype:2
+ media-libs/harfbuzz:=[truetype]
+ media-libs/jbig2dec:=
+ media-libs/libpng:0=
+ >=media-libs/libjpeg-turbo-1.5.3-r2:0=
+ net-misc/curl
+ javascript? ( >=dev-lang/mujs-1.2.0:= )
+ jpeg2k? ( >=media-libs/openjpeg-2.1:2= )
+ opengl? ( >=media-libs/freeglut-3.0.0 )
+ ssl? ( >=dev-libs/openssl-1.1:0= )
+ sys-libs/zlib
+ X? (
+ media-libs/libglvnd[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.15-CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.19.0-Makefile.patch
+ "${FILESDIR}"/${PN}-1.24.8-add-desktop-pc-files.patch
+ "${FILESDIR}"/${PN}-1.24.1-cross-fixes.patch
+ "${FILESDIR}"/${PN}-1.24.1-darwin.patch
+ # See bugs #662352
+ "${FILESDIR}"/${PN}-1.24.1-openssl-x11.patch
+ # General cross fixes from Debian (refreshed)
+ "${FILESDIR}"/${PN}-1.21.1-fix-aliasing-violation.patch
+ "${FILESDIR}"/${PN}-1.24.8-c23.patch
+)
+
+src_prepare() {
+ default
+
+ use hppa && append-cflags -ffunction-sections
+
+ append-cflags "-DFZ_ENABLE_JS=$(usex javascript 1 0)"
+
+ if ! use jpeg2k; then
+ append-cflags "-DFZ_ENABLE_JPX=0"
+ sed -i '/_OPENJPEG_/d' Makerules || die
+ # https://github.com/ArtifexSoftware/mupdf/pull/60
+ sed -i '/openjpeg.h/d' 'source/fitz/encode-jpx.c' || die
+ fi
+
+ sed -e "1iOS = Linux" \
+ -e "1iCC = $(tc-getCC)" \
+ -e "1iCXX = $(tc-getCXX)" \
+ -e "1iLD = $(tc-getLD)" \
+ -e "1iAR = $(tc-getAR)" \
+ -e "1iverbose = yes" \
+ -e "1ibuild = debug" \
+ -i Makerules || die "Failed adding build variables to Makerules in src_prepare()"
+
+ # Adjust MuPDF version in .pc file created by the
+ # [...]-add-desktop-pc-files.patch file
+ sed -e "s/Version: \(.*\)/Version: ${PV}/" \
+ -i platform/debian/${PN}.pc || die "Failed substituting version in ${PN}.pc"
+}
+
+_emake() {
+ # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
+ #
+ # Bundled libs
+ # * General
+ # Note that USE_SYSTEM_LIBS=yes is a metaoption which will set to upstream's
+ # recommendations. It does not mean "always use system libs".
+ # See [0] below for what it means in a specific version.
+ #
+ # * freeglut
+ # We don't use system's freeglut because upstream has a special modified
+ # version of it that gives mupdf clipboard support. See bug #653298
+ #
+ # * mujs
+ # As of v1.15.0, mupdf started using symbols in mujs that were not part
+ # of any release. We then went back to using the bundled version of it.
+ # But v1.17.0 looks ok, so we'll go unbundled again. Be aware of this risk
+ # when bumping and check!
+ # See bug #685244
+ #
+ # * lmms2
+ # mupdf uses a bundled version of lcms2 [0] because Artifex have forked it [1].
+ # It is therefore not appropriate for us to unbundle it at this time.
+ #
+ # [0] https://git.ghostscript.com/?p=mupdf.git;a=blob;f=Makethird;h=c4c540fa4a075df0db85e6fdaab809099881f35a;hb=HEAD#l9
+ # [1] https://www.ghostscript.com/doc/lcms2mt/doc/WhyThisFork.txt
+ local myemakeargs=(
+ GENTOO_PV=${PV}
+ HAVE_GLUT=$(usex opengl)
+ HAVE_LIBCRYPTO=$(usex ssl)
+ HAVE_X11=$(usex X)
+ USE_SYSTEM_LIBS=yes
+ USE_SYSTEM_MUJS=$(usex javascript)
+ USE_SYSTEM_GLUT=no
+ HAVE_OBJCOPY=no
+ "$@"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+
+ _emake XCFLAGS="-fPIC"
+}
+
+src_install() {
+ if use opengl || use X ; then
+ domenu platform/debian/${PN}.desktop
+ doicon -s scalable docs/logo/${PN}-icon.svg
+ else
+ rm docs/man/${PN}.1 || die "Failed to remove man page in src_install()"
+ fi
+
+ sed -i \
+ -e "1iprefix = ${ED}/usr" \
+ -e "1ilibdir = ${ED}/usr/$(get_libdir)" \
+ -e "1idocdir = ${ED}/usr/share/doc/${PF}" \
+ -i Makerules || die "Failed adding liprefix, lilibdir and lidocdir to Makerules in src_install()"
+
+ _emake install
+
+ dosym libmupdf.so.${PV} /usr/$(get_libdir)/lib${PN}.so
+
+ if use opengl ; then
+ einfo "mupdf symlink points to mupdf-gl (bug 616654)"
+ dosym ${PN}-gl /usr/bin/${PN}
+ elif use X ; then
+ einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
+ dosym ${PN}-x11 /usr/bin/${PN}
+ fi
+
+ # Respect libdir and EPREFIX (bugs #734898, #911965)
+ sed -i -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr:${EPREFIX}/usr:" platform/debian/${PN}.pc \
+ || die "Failed to sed pkgconfig file to respect libdir and EPREFIX in src_install()"
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins platform/debian/${PN}.pc
+
+ dodoc README CHANGES CONTRIBUTORS
+}
diff --git a/app-text/mupdf/mupdf-1.25.2.ebuild b/app-text/mupdf/mupdf-1.25.2.ebuild
index 84712856e9dc..9fa41b7e9bed 100644
--- a/app-text/mupdf/mupdf-1.25.2.ebuild
+++ b/app-text/mupdf/mupdf-1.25.2.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}"/${P}-source
LICENSE="AGPL-3"
SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ~ppc ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
IUSE="archive +javascript opengl ssl X"
REQUIRED_USE="opengl? ( javascript )"