summaryrefslogtreecommitdiff
path: root/app-text/namazu/namazu-2.0.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/namazu/namazu-2.0.21.ebuild')
-rw-r--r--app-text/namazu/namazu-2.0.21.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-text/namazu/namazu-2.0.21.ebuild b/app-text/namazu/namazu-2.0.21.ebuild
index ef46e76118df..866e3923c180 100644
--- a/app-text/namazu/namazu-2.0.21.ebuild
+++ b/app-text/namazu/namazu-2.0.21.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
inherit autotools elisp-common
@@ -35,9 +35,12 @@ BDEPEND="nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-configure.patch
"${FILESDIR}"/${PN}-emacs-27.patch
"${FILESDIR}"/${PN}-perl-5.18.patch
"${FILESDIR}"/${PN}-perl-5.26.patch
+ "${FILESDIR}"/${PN}-tests.patch
+ "${FILESDIR}"/${PN}-underlinking.patch
"${FILESDIR}"/${P}-memmove.patch
)
@@ -74,14 +77,12 @@ src_compile() {
fi
}
-src_test() {
- emake -j1 check
-}
-
src_install() {
default
find "${ED}" -name '*.la' -delete || die
+ keepdir /var/lib/${PN}/index
+
if use emacs; then
elisp-install ${PN} lisp/*.el*
elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el