summaryrefslogtreecommitdiff
path: root/app-text/poppler-data/poppler-data-0.4.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/poppler-data/poppler-data-0.4.7.ebuild')
-rw-r--r--app-text/poppler-data/poppler-data-0.4.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-text/poppler-data/poppler-data-0.4.7.ebuild b/app-text/poppler-data/poppler-data-0.4.7.ebuild
new file mode 100644
index 000000000000..8583800548d5
--- /dev/null
+++ b/app-text/poppler-data/poppler-data-0.4.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Data files for poppler to support uncommon encodings without xpdfrc"
+HOMEPAGE="https://poppler.freedesktop.org/"
+SRC_URI="https://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="BSD GPL-2 MIT"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+src_install() {
+ emake prefix="${EPREFIX}"/usr DESTDIR="${D}" install
+
+ # bug 409361
+ dodir /usr/share/poppler/cMaps
+ cd "${D}/${EPREFIX}"/usr/share/poppler/cMaps || die
+ find ../cMap -type f -exec ln -s {} . \; || die
+}