summaryrefslogtreecommitdiff
path: root/app-text/rnv/rnv-1.7.11-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rnv/rnv-1.7.11-r1.ebuild')
-rw-r--r--app-text/rnv/rnv-1.7.11-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/rnv/rnv-1.7.11-r1.ebuild b/app-text/rnv/rnv-1.7.11-r1.ebuild
new file mode 100644
index 000000000000..1ca31dcce3d1
--- /dev/null
+++ b/app-text/rnv/rnv-1.7.11-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit unpacker toolchain-funcs
+
+DESCRIPTION="A lightweight Relax NG Compact Syntax validator"
+HOMEPAGE="http://www.davidashen.net/rnv.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/expat
+ dev-scheme/scm[libscm]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "/^AR/s/ar/$(tc-getAR)/" Makefile.in || die 'sed on Makefile.in failed'
+}
+
+src_configure() {
+ LIBS="-ldl -lm" \
+ econf --with-scm="/usr"
+}
+
+src_install() {
+ default
+ dodoc readme.txt
+}