summaryrefslogtreecommitdiff
path: root/app-text/rpl/rpl-1.15.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rpl/rpl-1.15.5.ebuild')
-rw-r--r--app-text/rpl/rpl-1.15.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/rpl/rpl-1.15.5.ebuild b/app-text/rpl/rpl-1.15.5.ebuild
new file mode 100644
index 000000000000..94f430f1934e
--- /dev/null
+++ b/app-text/rpl/rpl-1.15.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="https://rpl.sourceforge.net/ https://github.com/rrthomas/rpl"
+SRC_URI="
+ https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/chainstream[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i "s/VERSION = importlib.metadata.version('rpl')/VERSION = '${PV}'/" rpl/__init__.py || die
+ distutils-r1_src_prepare
+}