summaryrefslogtreecommitdiff
path: root/app-text/ttf2pt1/files/ttf2pt1-3.4.4-LDFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ttf2pt1/files/ttf2pt1-3.4.4-LDFLAGS.patch')
-rw-r--r--app-text/ttf2pt1/files/ttf2pt1-3.4.4-LDFLAGS.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-text/ttf2pt1/files/ttf2pt1-3.4.4-LDFLAGS.patch b/app-text/ttf2pt1/files/ttf2pt1-3.4.4-LDFLAGS.patch
new file mode 100644
index 000000000000..3d03e03e14ca
--- /dev/null
+++ b/app-text/ttf2pt1/files/ttf2pt1-3.4.4-LDFLAGS.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 2616d46..cf72cba 100644
+--- a/Makefile
++++ b/Makefile
+@@ -179,7 +179,7 @@ app/RPM/ttf2pt1.spec: app/RPM/ttf2pt1.spec.src version.h
+ sed 's/^Version:.*/Version: '`grep TTF2PT1_VERSION version.h| cut -d\" -f2`'/' <app/RPM/ttf2pt1.spec.src >$@
+
+ t1asm: t1asm.c
+- $(CC) $(CFLAGS) -o t1asm -DSTANDALONE t1asm.c $(LIBS)
++ $(CC) $(CFLAGS) -o t1asm -DSTANDALONE t1asm.c $(LDFLAGS) $(LIBS)
+
+ ttf2pt1.o: ttf2pt1.c ttf.h pt1.h global.h version.h
+ $(CC) $(CFLAGS) -c ttf2pt1.c
+@@ -203,7 +203,7 @@ runt1asm.o: runt1asm.c global.h
+ $(CC) $(CFLAGS) $(CFLAGS_EXTT1ASM) -c runt1asm.c
+
+ ttf2pt1: ttf2pt1.o pt1.o runt1asm.o ttf.o ft.o bdf.o bitmap.o
+- $(CC) $(CFLAGS) -o ttf2pt1 ttf2pt1.o pt1.o runt1asm.o ttf.o ft.o bdf.o bitmap.o $(LIBS)
++ $(CC) $(CFLAGS) -o ttf2pt1 ttf2pt1.o pt1.o runt1asm.o ttf.o ft.o bdf.o bitmap.o $(LDFLAGS) $(LIBS)
+
+ CHANGES: CHANGES.html
+ scripts/unhtml <CHANGES.html >CHANGES