summaryrefslogtreecommitdiff
path: root/app-text/xpdf/xpdf-4.02-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xpdf/xpdf-4.02-r4.ebuild')
-rw-r--r--app-text/xpdf/xpdf-4.02-r4.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-text/xpdf/xpdf-4.02-r4.ebuild b/app-text/xpdf/xpdf-4.02-r4.ebuild
index 4311f1b32efa..288d1e759015 100644
--- a/app-text/xpdf/xpdf-4.02-r4.ebuild
+++ b/app-text/xpdf/xpdf-4.02-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="The PDF viewer and tools"
HOMEPAGE="https://www.xpdfreader.com"
@@ -65,7 +65,8 @@ src_prepare() {
sed -i "s|/usr/local|${EPREFIX}/usr|" "${WORKDIR}"/*/add-to-xpdfrc || die
fi
- cmake-utils_src_prepare
+ xdg_environment_reset
+ cmake_src_prepare
}
src_configure() {
@@ -80,13 +81,16 @@ src_configure() {
-DXPDFWIDGET_PRINTING=$(usex cups)
-DSYSTEM_XPDFRC="${EPREFIX}/etc/xpdfrc"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use icons; then
+ # in some cases inkscape tries to write font cache to the
+ # system dir, see bug 739166
+ addpredict /usr/share/inkscape/fonts
local inkarg="-e"
has_version -b '>media-gfx/inkscape-0.99' && inkarg="-o"
@@ -101,7 +105,7 @@ src_compile() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
domenu "${FILESDIR}/xpdf.desktop"
newicon -s scalable xpdf-qt/xpdf-icon.svg xpdf.svg