summaryrefslogtreecommitdiff
path: root/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-0.1.8.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.8.ebuild b/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
new file mode 100644
index 000000000000..431498d45edd
--- /dev/null
+++ b/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86"
+ SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
+HOMEPAGE="https://pwmt.org/projects/zathura-cb/"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND=">=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"