summaryrefslogtreecommitdiff
path: root/app-text/zathura-cb/zathura-cb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-9999.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index 227a2188c278..32698cdd593e 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -4,23 +4,21 @@
EAPI=5
inherit eutils toolchain-funcs readme.gentoo-r1
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="~amd64 ~arm ~x86"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/zathura-0.3.1
@@ -31,7 +29,7 @@ RDEPEND=">=app-text/zathura-0.3.1
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
@@ -47,13 +45,13 @@ src_compile() {
src_install() {
emake "${myzathuraconf[@]}" install
dodoc AUTHORS
+
+ FORCE_PRINT_ELOG=1
+ local DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
+ app-arch/unzip for additional file support."
readme.gentoo_create_doc
}
pkg_postinst() {
readme.gentoo_print_elog
}
-
-FORCE_PRINT_ELOG=1
-DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
-app-arch/unzip for additional file support."