summaryrefslogtreecommitdiff
path: root/app-vim/cctree
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/cctree')
-rw-r--r--app-vim/cctree/Manifest3
-rw-r--r--app-vim/cctree/cctree-1.61-r1.ebuild28
-rw-r--r--app-vim/cctree/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/app-vim/cctree/Manifest b/app-vim/cctree/Manifest
new file mode 100644
index 000000000000..39b028bc67fe
--- /dev/null
+++ b/app-vim/cctree/Manifest
@@ -0,0 +1,3 @@
+DIST cctree-1.61.tar.bz2 23243 BLAKE2B ba39d476ed68109a614cf5f626a44010aaa7e6154edf0c05f87973c46d95957a46fa22e29d73b0d3d602bae78039fd0bf6ef356d94f6570e0cea205bb6335572 SHA512 9d29c573ef3cdcde1ec91ca34684c84c8beb3b89669654b1f9dafab928a11d8f1df77294af06c7612ba8aa7d65dfba69352f3f74dd11c98d22a300907d8a6b0e
+EBUILD cctree-1.61-r1.ebuild 804 BLAKE2B 5aaf44b8cbfcc0dee1470e55b2a946f796456707474c5ce433db2c6c4579ca31f04ff18b22e99cbb07d27115b9aa4224cbb606ab23694544b71f95f91789c252 SHA512 0eb287aa4d494e57248350888c311ebdb92dc4e86c3bb79b45da4e25fc9313dd115717a7f9e8522f254293ef64ef9446dd19689eff66a679798ebcf687b0aebc
+MISC metadata.xml 332 BLAKE2B fa5f17b84fcf8c7beb06eb3ae508493f8f0240beb91be975323a2974991fdd9e82f639df0c2624d1d7741b11d5894f74256bb81994f636700a57ed6a7a57a3e0 SHA512 c1338d54664a59c207fe04fa762db7c824c289912564cb1ef206fde45883e6741426e9967efc2e1fd64594d3c89989b227c702caf45283aef658a03eaf443979
diff --git a/app-vim/cctree/cctree-1.61-r1.ebuild b/app-vim/cctree/cctree-1.61-r1.ebuild
new file mode 100644
index 000000000000..1cc0cf069e51
--- /dev/null
+++ b/app-vim/cctree/cctree-1.61-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="https://sites.google.com/site/vimcctree/"
+LICENSE="bufexplorer.vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc || die
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/${PN}.vim > doc/${PN}.txt || die
+
+ default
+}
diff --git a/app-vim/cctree/metadata.xml b/app-vim/cctree/metadata.xml
new file mode 100644
index 000000000000..8c235406518e
--- /dev/null
+++ b/app-vim/cctree/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-scripts/CCTree</remote-id>
+ </upstream>
+</pkgmetadata>