summaryrefslogtreecommitdiff
path: root/app-vim/conque/conque-2.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/conque/conque-2.3-r1.ebuild')
-rw-r--r--app-vim/conque/conque-2.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/conque/conque-2.3-r1.ebuild b/app-vim/conque/conque-2.3-r1.ebuild
new file mode 100644
index 000000000000..93ff4281f401
--- /dev/null
+++ b/app-vim/conque/conque-2.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit python-single-r1 vim-plugin
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="vim plugin: Run interactive commands inside a Vim buffer"
+HOMEPAGE="https://code.google.com/p/conque/"
+SRC_URI="https://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="ConqueTerm"
+
+S="${WORKDIR}/${MY_P}"