summaryrefslogtreecommitdiff
path: root/app-vim/jedi/jedi-0.8_p20171015-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/jedi/jedi-0.8_p20171015-r1.ebuild')
-rw-r--r--app-vim/jedi/jedi-0.8_p20171015-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/jedi/jedi-0.8_p20171015-r1.ebuild b/app-vim/jedi/jedi-0.8_p20171015-r1.ebuild
new file mode 100644
index 000000000000..654cb4c957eb
--- /dev/null
+++ b/app-vim/jedi/jedi-0.8_p20171015-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit vim-plugin python-r1 python-utils-r1
+
+# Commit Date: Sun Oct 15 20:51:54 2017 +0200
+COMMIT="77924398bd594e238766153cec97ace62650f082"
+
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/jedi[${PYTHON_USEDEP}]"
+DEPEND="app-editors/vim[python]"
+
+S="${WORKDIR}/jedi-vim-${COMMIT}"
+
+# Tests are broken.
+RESTRICT="test"
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_install() {
+ vim-plugin_src_install
+}