summaryrefslogtreecommitdiff
path: root/app-vim/nerdcommenter/nerdcommenter-2.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/nerdcommenter/nerdcommenter-2.5.1.ebuild')
-rw-r--r--app-vim/nerdcommenter/nerdcommenter-2.5.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/nerdcommenter/nerdcommenter-2.5.1.ebuild b/app-vim/nerdcommenter/nerdcommenter-2.5.1.ebuild
new file mode 100644
index 000000000000..e698dd51a16b
--- /dev/null
+++ b/app-vim/nerdcommenter/nerdcommenter-2.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/scrooloose/nerdcommenter.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="vim plugin: easy commenting of code for many filetypes"
+HOMEPAGE="https://github.com/scrooloose/nerdcommenter https://www.vim.org/scripts/script.php?script_id=1218"
+LICENSE="WTFPL-2 "
+
+VIM_PLUGIN_HELPFILES="NERD_commenter.txt"
+
+src_prepare() {
+ default
+ rm README.md Rakefile || die
+}