summaryrefslogtreecommitdiff
path: root/app-vim/showmarks
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/showmarks')
-rw-r--r--app-vim/showmarks/Manifest1
-rw-r--r--app-vim/showmarks/showmarks-2.2-r2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/showmarks/Manifest b/app-vim/showmarks/Manifest
index fd56a207f56e..0bc8292d910f 100644
--- a/app-vim/showmarks/Manifest
+++ b/app-vim/showmarks/Manifest
@@ -1,3 +1,4 @@
DIST showmarks-2.2.tar.bz2 8195 BLAKE2B 2be7ef6fc040fcc6d808771ac45523148685b466b5eb7ffc6c5b31f4a2387375c84aae931ffcb6494ecaa9cd9713567e9f7fa19981678cdffaecc38aa9f27bdf SHA512 0121070d8b8c51b3b31c1d052b368fac304ee38e413881e67e2b9336b1edcae6af165c592d592f42c502834856d2c097b575571286574ba83a51d4fc9964b7a3
EBUILD showmarks-2.2-r1.ebuild 836 BLAKE2B 4db0ebf081f3cc2ab83f7d15b18106f3eda8c3056a9af6b3d13675d2216e8eea5dd4f82d070936ad45cd99fe7ac310789f60484a34ef8b10800eb7b536709e5c SHA512 369ad4a48d68132bc31a7d0a8a2ab1f3610a5985399b17e2ed7d02b9b16305ed04f05e81b3e28b703568cec282923685b6815df68166a20de450bc5f1cd07b7f
+EBUILD showmarks-2.2-r2.ebuild 832 BLAKE2B f3aabedc5f48259f8a87bbbbc7177306b1ed62c62416b73d1e0352e00c3f0f253a9b1fa72308cba729171babdb568878cfae65aad4762a009b4774ef3485c525 SHA512 d3a27a24008eafac77eed26cac698bd476008b6725aea964ddbad68cb3647078e3c7514fb2245c5a3182a02dc027b1d215f3b64ebc0dcc997bf360d80e87c504
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/showmarks/showmarks-2.2-r2.ebuild b/app-vim/showmarks/showmarks-2.2-r2.ebuild
new file mode 100644
index 000000000000..247c654173bb
--- /dev/null
+++ b/app-vim/showmarks/showmarks-2.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: show location marks visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=152"
+
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+VIM_PLUGIN_HELPFILES="showmarks.txt"
+
+src_prepare() {
+ default
+
+ mkdir "${S}"/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic HelpExtractor' variant. This causes
+ # problems for us during the unmerge. Fortunately, sed can fix this
+ # for us.
+ sed -e '1,/^" HelpExtractorDoc:$/d' \
+ "${S}"/plugin/showmarks.vim > "${S}"/doc/showmarks.txt \
+ || die "help extraction failed"
+ sed -i -e '/^" HelpExtractor:$/,$d' "${S}"/plugin/showmarks.vim \
+ || die "help extract remove failed"
+}