summaryrefslogtreecommitdiff
path: root/dev-ada/aunit/aunit-2017.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada/aunit/aunit-2017.ebuild')
-rw-r--r--dev-ada/aunit/aunit-2017.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ada/aunit/aunit-2017.ebuild b/dev-ada/aunit/aunit-2017.ebuild
deleted file mode 100644
index b56e55701892..000000000000
--- a/dev-ada/aunit/aunit-2017.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multiprocessing
-
-MYP=${PN}-gpl-${PV}-src
-
-DESCRIPTION="Ada unit testing framework"
-HOMEPAGE="http://libre.adacore.com/tools/aunit/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/591c45e2c7a447af2deed000
- -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnat_2016 +gnat_2017"
-
-RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
- gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[gnat_2016=,gnat_2017=]"
-
-REQUIRED_USE="^^ ( gnat_2016 gnat_2017 )"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
-
-src_compile() {
- emake GPRBUILD="gprbuild -j$(makeopts_jobs)"
-}
-
-src_install() {
- emake INSTALL="${D}"usr install
- einstalldocs
- mv "${D}"usr/share/doc/${PN}/* "${D}"usr/share/doc/${PF}/ || die
- rmdir "${D}"usr/share/doc/${PN} || die
- mv "${D}"usr/share/examples/${PN} "${D}"usr/share/doc/${PF}/examples || die
- rmdir "${D}"usr/share/examples || die
-}