summaryrefslogtreecommitdiff
path: root/dev-build/muon/muon-0.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/muon/muon-0.2.0-r1.ebuild')
-rw-r--r--dev-build/muon/muon-0.2.0-r1.ebuild31
1 files changed, 5 insertions, 26 deletions
diff --git a/dev-build/muon/muon-0.2.0-r1.ebuild b/dev-build/muon/muon-0.2.0-r1.ebuild
index a6f3e8102624..6f2e8fcbdd8d 100644
--- a/dev-build/muon/muon-0.2.0-r1.ebuild
+++ b/dev-build/muon/muon-0.2.0-r1.ebuild
@@ -3,8 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
-inherit meson python-any-r1
+inherit meson
COMMIT_HASH="${PV}"
MESON_DOCS_TAR=meson-docs-0.64.1-19-g39c6fa4bc.tar.gz
@@ -13,16 +12,13 @@ DESCRIPTION="A meson-compatible build system"
HOMEPAGE="https://muon.build/"
SRC_URI="
https://git.sr.ht/~lattis/muon/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz
- man? (
- https://mochiro.moe/wrap/${MESON_DOCS_TAR}
- )
"
# Apache-2.0 for meson-docs
-LICENSE="GPL-3 man? ( Apache-2.0 )"
+LICENSE="GPL-3 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
-IUSE="+archive +curl +libpkgconf +man"
+IUSE="+archive +curl +libpkgconf"
S="${WORKDIR}/${PN}-${COMMIT_HASH}"
@@ -30,31 +26,14 @@ DEPEND="
curl? ( net-misc/curl )
archive? ( app-arch/libarchive:= )
libpkgconf? ( dev-util/pkgconf:= )
- man? ( app-text/scdoc )
"
RDEPEND="${DEPEND}"
BDEPEND="
- man? (
- $(python_gen_any_dep '
- dev-python/pyyaml[${PYTHON_USEDEP}]
- ')
- )
+ app-text/scdoc
"
-python_check_deps() {
- python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use man && python-any-r1_pkg_setup
-}
-
src_prepare() {
default
-
- if use man; then
- mv "${WORKDIR}/meson-docs" "${S}/subprojects" || die
- fi
}
src_configure() {
@@ -62,7 +41,7 @@ src_configure() {
$(meson_feature curl libcurl)
$(meson_feature archive libarchive)
$(meson_feature libpkgconf)
- $(meson_feature man docs)
+ -Ddocs=enabled
-Dsamurai=disabled # patched version of samurai downloaded via wraps
-Dbestline=enabled # vendored bestline, an insignificant addition
)