summaryrefslogtreecommitdiff
path: root/dev-build
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/Manifest.gzbin7380 -> 7376 bytes
-rw-r--r--dev-build/dolphin-plugins-makefileactions/Manifest2
-rw-r--r--dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.12.2.ebuild60
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-build/Manifest.gz b/dev-build/Manifest.gz
index f72029968732..5741fc7b92ee 100644
--- a/dev-build/Manifest.gz
+++ b/dev-build/Manifest.gz
Binary files differ
diff --git a/dev-build/dolphin-plugins-makefileactions/Manifest b/dev-build/dolphin-plugins-makefileactions/Manifest
index 509eff74475f..3f0eae563ad2 100644
--- a/dev-build/dolphin-plugins-makefileactions/Manifest
+++ b/dev-build/dolphin-plugins-makefileactions/Manifest
@@ -1,5 +1,7 @@
DIST dolphin-plugins-24.08.3.tar.xz 317540 BLAKE2B 54fa2e13be2cceb53b12b1edb2d6d7c1793f6ba2bbec67e9e00121b33683aa6bd4895392cbdf5aa7627958c6323984ae3db8b5bbf6b14faba86b13181e0a2614 SHA512 05da7ac7b3ebe085cf0808d8e1eba49372bfeb1488800f40c1d0b9025e743efede1200095a1e660c1d538b2cc1b19f0f717f3d0723043517859f5c2015f961ce
DIST dolphin-plugins-24.12.1.tar.xz 319152 BLAKE2B afb5d587e38d1fc24117a083eedc5d970ceeed93e0bbfe13fb991a85046224730c5a1490337ac82a04b613c216f1dd6be07de514c664c80e2e5a0f70bd7615cc SHA512 ebae4d9d363f6928eb89ceede74ca0cc3e0707f81fe782b07fb4d4e3c06bcb266f4981bc5f0374b76bf55b8e86d427bbab0a0fbf82552a288ab8ddb9916f5df9
+DIST dolphin-plugins-24.12.2.tar.xz 319000 BLAKE2B 6196e9eaec24106ff31ed5251bc21b5d9b493eb0d1e6ac916f869ab43694d4f214d045ba97ad9db0539cfcef5c4398a43c0c257f2ce5cae405608d7508939fa7 SHA512 78843785e35631ee6cdbe4fa9c259960029e01a0ad6eb28858a320187ebf47df9999b0766fc423383313db2852a9a35079a2317881ecb301c0fa48db902868e6
EBUILD dolphin-plugins-makefileactions-24.08.3.ebuild 1406 BLAKE2B df708c442170b69f7c0b4b9abe88c910a83ebd75dff281d84ef007bd10bf48c9e1cba35d023f9a6ecefa49293f4468ac54db4689f3e034bb7c68c47b385fcd5d SHA512 14b42186b3f75339d95dfad4308ca9cf30f8be25e5ccfae60b7199bce523e732f6dc2c99f84b956941163a2c47e555133912760187a94e6dbc508a6118cc5d0f
EBUILD dolphin-plugins-makefileactions-24.12.1.ebuild 1408 BLAKE2B a6c4fc7fa72b8a25e96efbf4baf601b3ab9bd79eedaadd6ec059144b90564166afe8fe34ebad4ddcda90e76f23e724f145faa475cb58594ce5cd5ff2b9e5ddcd SHA512 fe7e84520d35ccc4b34409aa62d90d1ffe1e572065fbc3a74a7f5cd532a713912302b218d2995df017ba4f395859cac8c82b8f80079d1c3ad99df8b13b1ab44e
+EBUILD dolphin-plugins-makefileactions-24.12.2.ebuild 1408 BLAKE2B a6c4fc7fa72b8a25e96efbf4baf601b3ab9bd79eedaadd6ec059144b90564166afe8fe34ebad4ddcda90e76f23e724f145faa475cb58594ce5cd5ff2b9e5ddcd SHA512 fe7e84520d35ccc4b34409aa62d90d1ffe1e572065fbc3a74a7f5cd532a713912302b218d2995df017ba4f395859cac8c82b8f80079d1c3ad99df8b13b1ab44e
MISC metadata.xml 410 BLAKE2B 19c3aebce470d75ce9a551aa1100eec6faaf74fa06e74159d859ec31732a3a80170ecfbfe08edd931f9be9a00473ed6485bc2e23a65f7fe18339103cdc909f49 SHA512 752a847319ebf8d110347da3e6949f0ca6847c18453bf2b9a465a8415c79f37b4aefb03cc7fcf6874039c38ff4ee375715892a616c2766e1fd689c18c8b05c10
diff --git a/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.12.2.ebuild b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.12.2.ebuild
new file mode 100644
index 000000000000..c56c72b8f9ba
--- /dev/null
+++ b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.12.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="makefileactions"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.7.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Makefile targets integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/dolphin-plugins-subversion-24.08.2-r1
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # kcompletion, ktextwidgets only required by other plugins
+ ecm_punt_kf_module Completion
+ ecm_punt_kf_module TextWidgets
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}