summaryrefslogtreecommitdiff
path: root/dev-cpp/doctest/doctest-2.4.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/doctest/doctest-2.4.10.ebuild')
-rw-r--r--dev-cpp/doctest/doctest-2.4.10.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-cpp/doctest/doctest-2.4.10.ebuild b/dev-cpp/doctest/doctest-2.4.10.ebuild
deleted file mode 100644
index b2da0710bd8a..000000000000
--- a/dev-cpp/doctest/doctest-2.4.10.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="The fastest feature-rich C++11/14/17/20 single-header testing framework"
-HOMEPAGE="https://github.com/doctest/doctest"
-SRC_URI="https://github.com/doctest/doctest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- sed -i '/-Werror/d' scripts/cmake/common.cmake || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDOCTEST_WITH_TESTS=$(usex test)
- )
- cmake_src_configure
-}