summaryrefslogtreecommitdiff
path: root/dev-cpp/doctest/doctest-2.4.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/doctest/doctest-2.4.7.ebuild')
-rw-r--r--dev-cpp/doctest/doctest-2.4.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/doctest/doctest-2.4.7.ebuild b/dev-cpp/doctest/doctest-2.4.7.ebuild
new file mode 100644
index 000000000000..ef28c59976ca
--- /dev/null
+++ b/dev-cpp/doctest/doctest-2.4.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The fastest feature-rich C++11/14/17/20 single-header testing framework"
+HOMEPAGE="https://github.com/doctest/doctest"
+SRC_URI="https://github.com/doctest/doctest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCTEST_WITH_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}