summaryrefslogtreecommitdiff
path: root/dev-cpp/muParser/muParser-2.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/muParser/muParser-2.3.4.ebuild')
-rw-r--r--dev-cpp/muParser/muParser-2.3.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/muParser/muParser-2.3.4.ebuild b/dev-cpp/muParser/muParser-2.3.4.ebuild
new file mode 100644
index 000000000000..4dd7dfcdf406
--- /dev/null
+++ b/dev-cpp/muParser/muParser-2.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="https://beltoforion.de/en/muparser/"
+SRC_URI="https://github.com/beltoforion/muparser/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/muparser-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc openmp test wchar"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_OPENMP=$(usex openmp)
+ -DENABLE_WIDE_CHAR=$(usex wchar)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_compile test
+}
+
+src_install() {
+ cmake_src_install
+}