summaryrefslogtreecommitdiff
path: root/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch')
-rw-r--r--dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch b/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
deleted file mode 100644
index 2da3c00c1612..000000000000
--- a/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Use catch library from system
-
---- a/tests/runtime_tests/CMakeLists.txt
-+++ b/tests/runtime_tests/CMakeLists.txt
-@@ -22,12 +22,6 @@
-
- # # # # sol3 tests - runtime tests
-
--if (CMAKE_GENERATOR MATCHES "Visual Studio 14 2015")
-- find_package(Catch 1.12.1 REQUIRED)
--else()
-- find_package(Catch REQUIRED)
--endif()
--
- file(GLOB SOL2_RUNTIME_TEST_SOURCES source/*.cpp)
- source_group(test_sources FILES ${SOL2_RUNTIME_TEST_SOURCES})
-
-@@ -38,7 +32,8 @@ function(CREATE_TEST test_target_name test_name target_sol)
- OUTPUT_NAME ${test_name}
- EXPORT_NAME sol2::${test_name})
- target_link_libraries(${test_target_name}
-- PUBLIC Threads::Threads ${LUA_LIBRARIES} ${CATCH_LIBRARIES} ${target_sol})
-+ PUBLIC Threads::Threads ${LUA_LIBRARIES} ${target_sol})
-+ target_include_directories(${test_target_name} PRIVATE ${CATCH_INC_DIR})
-
- if (MSVC)
- if (NOT CMAKE_COMPILER_ID MATCHES "Clang")