summaryrefslogtreecommitdiff
path: root/dev-cpp/tclap
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tclap')
-rw-r--r--dev-cpp/tclap/Manifest3
-rw-r--r--dev-cpp/tclap/metadata.xml8
-rw-r--r--dev-cpp/tclap/tclap-1.2.1.ebuild24
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/tclap/Manifest b/dev-cpp/tclap/Manifest
new file mode 100644
index 000000000000..73c11d82f557
--- /dev/null
+++ b/dev-cpp/tclap/Manifest
@@ -0,0 +1,3 @@
+DIST tclap-1.2.1.tar.gz 442387 BLAKE2B 413d77f59224dd7751621f32a5712178c4954cb532095203a1eb839c97d20e8651f94f90d4961a47f654d5b478946fb988db66df0d17c8230fde0b771af77405 SHA512 8bd6ee724600880840048c7b36f02d31b1aa4910b17f80fb04aef89b1f1917856d9979ec488edbd457b66d9d689aea97540abb842a8b902bbd75c66a6e07b9b1
+EBUILD tclap-1.2.1.ebuild 570 BLAKE2B f8657c52bf383ba97efe4c716d59be9d085c82bc01b6175e8b4351151953017f9c89cb8a5ea9e6ac410ee88378d8b1c5ca08cd9b219a216a45349632286197a9 SHA512 f8de56c7311945e191f222517b4265649bbe172c6c3262c79a4aec8738c8d4721438aac503b5e06c0c53dc18b4be4a9a8d0b1b094787862e8c4645ac79da0b9d
+MISC metadata.xml 242 BLAKE2B 82d9a3ad5f6403991bbdd339716e18a462985eaa3980968d67042c7a9541c070363f43924fb9f203a29e73ae2d1023e3b8ab7e307dc381ac5cdb55a588407a0b SHA512 95904a3f7981543557133918ba83a467f03e6839b3248651dc94870f1b8c3788ac50279d59886c54d12328891964c942e1bbd4e1c9d88837643ded5678a10a85
diff --git a/dev-cpp/tclap/metadata.xml b/dev-cpp/tclap/metadata.xml
new file mode 100644
index 000000000000..71114a4fc927
--- /dev/null
+++ b/dev-cpp/tclap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">tclap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/tclap/tclap-1.2.1.ebuild b/dev-cpp/tclap/tclap-1.2.1.ebuild
new file mode 100644
index 000000000000..4e4d959393f3
--- /dev/null
+++ b/dev-cpp/tclap/tclap-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="Simple templatized C++ library for parsing command line arguments"
+HOMEPAGE="http://tclap.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc x86 ~amd64-linux"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}