summaryrefslogtreecommitdiff
path: root/dev-cpp/tree/tree-2.81.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tree/tree-2.81.ebuild')
-rw-r--r--dev-cpp/tree/tree-2.81.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-cpp/tree/tree-2.81.ebuild b/dev-cpp/tree/tree-2.81.ebuild
index dc164fccce71..8bf33d70b234 100644
--- a/dev-cpp/tree/tree-2.81.ebuild
+++ b/dev-cpp/tree/tree-2.81.ebuild
@@ -8,15 +8,17 @@ inherit toolchain-funcs
DESCRIPTION="An STL-like tree class"
HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
SRC_URI="http://www.aei.mpg.de/~peekas/tree/${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc"
-S="${WORKDIR}/${P}/src"
-
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/${P}-gcc11.patch
+)
src_configure() {
tc-export CXX