summaryrefslogtreecommitdiff
path: root/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/waylandpp/waylandpp-0.1.0.ebuild')
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
deleted file mode 100644
index 112c1a2776d8..000000000000
--- a/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit scons-utils toolchain-funcs versionator
-
-DESCRIPTION="Wayland C++ bindings"
-HOMEPAGE="https://github.com/NilsBrause/waylandpp"
-
-LICENSE="MIT"
-IUSE="doc"
-SLOT="0/$(get_major_version)"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-RDEPEND="
- >=dev-libs/wayland-1.11.0
- media-libs/mesa[wayland]
-"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
- "
-
-src_prepare() {
- default
- sed -i -e "s:\$\${prefix}/lib:$\${prefix}/$(get_libdir):" -e "s:os.path.join(prefix, \"lib\":os.path.join(prefix, \"$(get_libdir)\":g" SConstruct || die
-}
-
-src_compile() {
- CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" PREFIX="${D%/}/usr" escons
- if use doc; then
- doxygen || die "error making docs"
- fi
-}
-
-src_install() {
- CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" PREFIX="${D%/}/usr" escons install
- # fix multilib-strict QA failures
- if use doc; then
- doman doc/man/man3/*.3
- local HTML_DOCS=( doc/html )
- einstalldocs
- fi
-}