summaryrefslogtreecommitdiff
path: root/dev-db/cdb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/cdb')
-rw-r--r--dev-db/cdb/Manifest5
-rw-r--r--dev-db/cdb/cdb-0.75-r4.ebuild52
-rw-r--r--dev-db/cdb/files/cdb-0.75-errno.diff11
-rw-r--r--dev-db/cdb/files/cdb-0.75-stdint.diff436
-rw-r--r--dev-db/cdb/metadata.xml5
5 files changed, 509 insertions, 0 deletions
diff --git a/dev-db/cdb/Manifest b/dev-db/cdb/Manifest
new file mode 100644
index 000000000000..b45728960314
--- /dev/null
+++ b/dev-db/cdb/Manifest
@@ -0,0 +1,5 @@
+AUX cdb-0.75-errno.diff 243 BLAKE2B e0b2433529e8ade1c4802353017948fd709f47843f339d8e1f77f9c665ece80721613d2dce8c9e67b595ee03f9b7298b04f927a26ad0bf8b5e38a10836799c81 SHA512 03c64d2ab185c16d88f51aaa12d1ca06102444c3eed9d712fcd53e6b8eaeeeacbdf525d91c7fc3eb28bf88be776de4748157d596103b9fc7776a5bde05eef4c4
+AUX cdb-0.75-stdint.diff 11423 BLAKE2B 85f0c3d1b2908c001ebdb055ebe4d7a79bf16a61d1d3ce8295e17cc9c0d5f1d7859465e3dba377a2857741ef082efb621c0cb77179bc6208b35120d390b71f53 SHA512 0308d25c6f9ee3b8fc49e75a2e69c7cdbf8cca7dbf165b3a107d5e2717051f6c68df04a962456295c56e6dde97ee0777944cf406c3eb48f4b7f39ecfaf56f877
+DIST cdb-0.75.tar.gz 54162 BLAKE2B 7b488bf330b2aac88a1cca82a6a49e24d0fd953c77935231a31bd72cc0936a37628736b5b22ea0d58aaa77cd118976ab8aa82ccc080f99e190e3f1db5d51b622 SHA512 6faeab91a77457348b58f685e81000b83fb609691317198a06284c5c62dee1e4d6138f90be1e727021f279d740169c175a21b23c96adb39a654e3f7fafdf36c0
+EBUILD cdb-0.75-r4.ebuild 1501 BLAKE2B c902dc285bd0ece506899636df6008a2a56653812c25344624f5eef7f1bff8b60d674173fdd8f5bda7723e554e841658f81639cff7aca282f035007fedcb968a SHA512 ab8e65b45cd1de6533f61e69d79cb26f84c18545e644c8d62c49d69bf99cfc945be9f1a53ae67c17f21a5e595189c722427382b92af2d33b404a3ea1a750a75d
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-db/cdb/cdb-0.75-r4.ebuild b/dev-db/cdb/cdb-0.75-r4.ebuild
new file mode 100644
index 000000000000..2c365e5f26c9
--- /dev/null
+++ b/dev-db/cdb/cdb-0.75-r4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DESCRIPTION="Fast, reliable, simple package for creating and reading constant databases"
+HOMEPAGE="http://cr.yp.to/cdb.html"
+SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4
+ !dev-db/tinycdb"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-errno.diff
+ epatch "${FILESDIR}"/${P}-stdint.diff
+
+ sed -i -e 's/head -1/head -n 1/g' Makefile \
+ || die "sed Makefile failed"
+}
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} -fPIC" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${EPREFIX}/usr" > conf-home
+}
+
+src_install() {
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest \
+ || die "dobin failed"
+
+ # ok so ... first off, some automakes fail at finding
+ # cdb.a, so install that now
+ dolib *.a || die "dolib failed"
+
+ # then do this pretty little symlinking to solve the somewhat
+ # cosmetic library issue at hand
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "dosym failed"
+
+ # uint32.h needs installation too, otherwise compiles depending
+ # on it will fail
+ insinto /usr/include/cdb
+ doins cdb*.h buffer.h alloc.h uint32.h || die "doins failed"
+
+ dodoc CHANGES FILES README SYSDEPS TODO VERSION
+}
diff --git a/dev-db/cdb/files/cdb-0.75-errno.diff b/dev-db/cdb/files/cdb-0.75-errno.diff
new file mode 100644
index 000000000000..5f6ac20c59c6
--- /dev/null
+++ b/dev-db/cdb/files/cdb-0.75-errno.diff
@@ -0,0 +1,11 @@
+--- error.h.orig 2003-03-29 04:18:26.000000000 -0800
++++ error.h 2003-03-29 04:19:00.000000000 -0800
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/dev-db/cdb/files/cdb-0.75-stdint.diff b/dev-db/cdb/files/cdb-0.75-stdint.diff
new file mode 100644
index 000000000000..eb564512075e
--- /dev/null
+++ b/dev-db/cdb/files/cdb-0.75-stdint.diff
@@ -0,0 +1,436 @@
+diff -Naur cdb-0.75-orig/cdb.c cdb-0.75/cdb.c
+--- cdb-0.75-orig/cdb.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdb.c 2009-01-16 19:46:17.000000000 +0100
+@@ -41,7 +41,7 @@
+ }
+ }
+
+-int cdb_read(struct cdb *c,char *buf,unsigned int len,uint32 pos)
++int cdb_read(struct cdb *c,char *buf,unsigned int len,uint32_t pos)
+ {
+ if (c->map) {
+ if ((pos > c->size) || (c->size - pos < len)) goto FORMAT;
+@@ -67,7 +67,7 @@
+ return -1;
+ }
+
+-static int match(struct cdb *c,char *key,unsigned int len,uint32 pos)
++static int match(struct cdb *c,char *key,unsigned int len,uint32_t pos)
+ {
+ char buf[32];
+ int n;
+@@ -87,8 +87,8 @@
+ int cdb_findnext(struct cdb *c,char *key,unsigned int len)
+ {
+ char buf[8];
+- uint32 pos;
+- uint32 u;
++ uint32_t pos;
++ uint32_t u;
+
+ if (!c->loop) {
+ u = cdb_hash(key,len);
+diff -Naur cdb-0.75-orig/cdbdump.c cdb-0.75/cdbdump.c
+--- cdb-0.75-orig/cdbdump.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdbdump.c 2009-01-16 19:46:17.000000000 +0100
+@@ -18,7 +18,7 @@
+ if (buffer_flush(buffer_1) == -1) die_write();
+ }
+
+-uint32 pos = 0;
++uint32_t pos = 0;
+
+ void get(char *buf,unsigned int len)
+ {
+@@ -37,7 +37,7 @@
+
+ char buf[512];
+
+-void copy(uint32 len)
++void copy(uint32_t len)
+ {
+ unsigned int x;
+
+@@ -50,7 +50,7 @@
+ }
+ }
+
+-void getnum(uint32 *num)
++void getnum(uint32_t *num)
+ {
+ get(buf,4);
+ uint32_unpack(buf,num);
+@@ -60,9 +60,9 @@
+
+ main()
+ {
+- uint32 eod;
+- uint32 klen;
+- uint32 dlen;
++ uint32_t eod;
++ uint32_t klen;
++ uint32_t dlen;
+
+ getnum(&eod);
+ while (pos < 2048) getnum(&dlen);
+diff -Naur cdb-0.75-orig/cdbget.c cdb-0.75/cdbget.c
+--- cdb-0.75-orig/cdbget.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdbget.c 2009-01-16 19:46:17.000000000 +0100
+@@ -27,8 +27,8 @@
+ {
+ char *key;
+ int r;
+- uint32 pos;
+- uint32 len;
++ uint32_t pos;
++ uint32_t len;
+ unsigned long u = 0;
+
+ if (!*argv) die_usage();
+diff -Naur cdb-0.75-orig/cdb.h cdb-0.75/cdb.h
+--- cdb-0.75-orig/cdb.h 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdb.h 2009-01-16 19:46:17.000000000 +0100
+@@ -6,26 +6,26 @@
+ #include "uint32.h"
+
+ #define CDB_HASHSTART 5381
+-extern uint32 cdb_hashadd(uint32,unsigned char);
+-extern uint32 cdb_hash(char *,unsigned int);
++extern uint32_t cdb_hashadd(uint32_t,unsigned char);
++extern uint32_t cdb_hash(char *,unsigned int);
+
+ struct cdb {
+ char *map; /* 0 if no map is available */
+ int fd;
+- uint32 size; /* initialized if map is nonzero */
+- uint32 loop; /* number of hash slots searched under this key */
+- uint32 khash; /* initialized if loop is nonzero */
+- uint32 kpos; /* initialized if loop is nonzero */
+- uint32 hpos; /* initialized if loop is nonzero */
+- uint32 hslots; /* initialized if loop is nonzero */
+- uint32 dpos; /* initialized if cdb_findnext() returns 1 */
+- uint32 dlen; /* initialized if cdb_findnext() returns 1 */
++ uint32_t size; /* initialized if map is nonzero */
++ uint32_t loop; /* number of hash slots searched under this key */
++ uint32_t khash; /* initialized if loop is nonzero */
++ uint32_t kpos; /* initialized if loop is nonzero */
++ uint32_t hpos; /* initialized if loop is nonzero */
++ uint32_t hslots; /* initialized if loop is nonzero */
++ uint32_t dpos; /* initialized if cdb_findnext() returns 1 */
++ uint32_t dlen; /* initialized if cdb_findnext() returns 1 */
+ } ;
+
+ extern void cdb_free(struct cdb *);
+ extern void cdb_init(struct cdb *,int fd);
+
+-extern int cdb_read(struct cdb *,char *,unsigned int,uint32);
++extern int cdb_read(struct cdb *,char *,unsigned int,uint32_t);
+
+ extern void cdb_findstart(struct cdb *);
+ extern int cdb_findnext(struct cdb *,char *,unsigned int);
+diff -Naur cdb-0.75-orig/cdb_hash.c cdb-0.75/cdb_hash.c
+--- cdb-0.75-orig/cdb_hash.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdb_hash.c 2009-01-16 19:46:17.000000000 +0100
+@@ -2,15 +2,15 @@
+
+ #include "cdb.h"
+
+-uint32 cdb_hashadd(uint32 h,unsigned char c)
++uint32_t cdb_hashadd(uint32_t h,unsigned char c)
+ {
+ h += (h << 5);
+ return h ^ c;
+ }
+
+-uint32 cdb_hash(char *buf,unsigned int len)
++uint32_t cdb_hash(char *buf,unsigned int len)
+ {
+- uint32 h;
++ uint32_t h;
+
+ h = CDB_HASHSTART;
+ while (len) {
+diff -Naur cdb-0.75-orig/cdb_make.c cdb-0.75/cdb_make.c
+--- cdb-0.75-orig/cdb_make.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdb_make.c 2009-01-16 19:51:05.000000000 +0100
+@@ -19,15 +19,15 @@
+ return seek_set(fd,c->pos);
+ }
+
+-static int posplus(struct cdb_make *c,uint32 len)
++static int posplus(struct cdb_make *c,uint32_t len)
+ {
+- uint32 newpos = c->pos + len;
++ uint32_t newpos = c->pos + len;
+ if (newpos < len) { errno = error_nomem; return -1; }
+ c->pos = newpos;
+ return 0;
+ }
+
+-int cdb_make_addend(struct cdb_make *c,unsigned int keylen,unsigned int datalen,uint32 h)
++int cdb_make_addend(struct cdb_make *c,unsigned int keylen,unsigned int datalen,uint32_t h)
+ {
+ struct cdb_hplist *head;
+
+@@ -74,11 +74,11 @@
+ {
+ char buf[8];
+ int i;
+- uint32 len;
+- uint32 u;
+- uint32 memsize;
+- uint32 count;
+- uint32 where;
++ uint32_t len;
++ uint32_t u;
++ uint32_t memsize;
++ uint32_t count;
++ uint32_t where;
+ struct cdb_hplist *x;
+ struct cdb_hp *hp;
+
+@@ -99,7 +99,7 @@
+ }
+
+ memsize += c->numentries; /* no overflow possible up to now */
+- u = (uint32) 0 - (uint32) 1;
++ u = UINT32_MAX;
+ u /= sizeof(struct cdb_hp);
+ if (memsize > u) { errno = error_nomem; return -1; }
+
+diff -Naur cdb-0.75-orig/cdbmake.c cdb-0.75/cdbmake.c
+--- cdb-0.75-orig/cdbmake.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdbmake.c 2009-01-16 19:46:17.000000000 +0100
+@@ -41,7 +41,7 @@
+ unsigned int klen;
+ unsigned int dlen;
+ unsigned int i;
+- uint32 h;
++ uint32_t h;
+ int fd;
+ char ch;
+
+diff -Naur cdb-0.75-orig/cdb_make.h cdb-0.75/cdb_make.h
+--- cdb-0.75-orig/cdb_make.h 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdb_make.h 2009-01-16 19:46:17.000000000 +0100
+@@ -8,7 +8,7 @@
+
+ #define CDB_HPLIST 1000
+
+-struct cdb_hp { uint32 h; uint32 p; } ;
++struct cdb_hp { uint32_t h; uint32_t p; } ;
+
+ struct cdb_hplist {
+ struct cdb_hp hp[CDB_HPLIST];
+@@ -19,20 +19,20 @@
+ struct cdb_make {
+ char bspace[8192];
+ char final[2048];
+- uint32 count[256];
+- uint32 start[256];
++ uint32_t count[256];
++ uint32_t start[256];
+ struct cdb_hplist *head;
+ struct cdb_hp *split; /* includes space for hash */
+ struct cdb_hp *hash;
+- uint32 numentries;
++ uint32_t numentries;
+ buffer b;
+- uint32 pos;
++ uint32_t pos;
+ int fd;
+ } ;
+
+ extern int cdb_make_start(struct cdb_make *,int);
+ extern int cdb_make_addbegin(struct cdb_make *,unsigned int,unsigned int);
+-extern int cdb_make_addend(struct cdb_make *,unsigned int,unsigned int,uint32);
++extern int cdb_make_addend(struct cdb_make *,unsigned int,unsigned int,uint32_t);
+ extern int cdb_make_add(struct cdb_make *,char *,unsigned int,char *,unsigned int);
+ extern int cdb_make_finish(struct cdb_make *);
+
+diff -Naur cdb-0.75-orig/cdbstats.c cdb-0.75/cdbstats.c
+--- cdb-0.75-orig/cdbstats.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdbstats.c 2009-01-16 19:46:17.000000000 +0100
+@@ -28,7 +28,7 @@
+ if (buffer_flush(buffer_1small) == -1) die_write();
+ }
+
+-uint32 pos = 0;
++uint32_t pos = 0;
+
+ void get(char *buf,unsigned int len)
+ {
+@@ -43,7 +43,7 @@
+ }
+ }
+
+-void getnum(uint32 *num)
++void getnum(uint32_t *num)
+ {
+ char buf[4];
+ get(buf,4);
+@@ -70,9 +70,9 @@
+
+ main()
+ {
+- uint32 eod;
+- uint32 klen;
+- uint32 dlen;
++ uint32_t eod;
++ uint32_t klen;
++ uint32_t dlen;
+ seek_pos rest;
+ int r;
+
+diff -Naur cdb-0.75-orig/cdbtest.c cdb-0.75/cdbtest.c
+--- cdb-0.75-orig/cdbtest.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/cdbtest.c 2009-01-16 19:46:17.000000000 +0100
+@@ -24,7 +24,7 @@
+ if (buffer_flush(buffer_1small) == -1) die_write();
+ }
+
+-uint32 pos = 0;
++uint32_t pos = 0;
+
+ void get(char *buf,unsigned int len)
+ {
+@@ -40,7 +40,7 @@
+ }
+ }
+
+-void getnum(uint32 *num)
++void getnum(uint32_t *num)
+ {
+ char buf[4];
+ get(buf,4);
+@@ -68,9 +68,9 @@
+
+ main()
+ {
+- uint32 eod;
+- uint32 klen;
+- uint32 dlen;
++ uint32_t eod;
++ uint32_t klen;
++ uint32_t dlen;
+ seek_pos rest;
+ int r;
+
+diff -Naur cdb-0.75-orig/Makefile cdb-0.75/Makefile
+--- cdb-0.75-orig/Makefile 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/Makefile 2009-01-16 19:46:17.000000000 +0100
+@@ -298,13 +298,6 @@
+ uint32.h
+ ./compile testzero.c
+
+-uint32.h: \
+-tryulong32.c compile load uint32.h1 uint32.h2
+- ( ( ./compile tryulong32.c && ./load tryulong32 && \
+- ./tryulong32 ) >/dev/null 2>&1 \
+- && cat uint32.h2 || cat uint32.h1 ) > uint32.h
+- rm -f tryulong32.o tryulong32
+-
+ uint32_pack.o: \
+ compile uint32_pack.c uint32.h
+ ./compile uint32_pack.c
+diff -Naur cdb-0.75-orig/TARGETS cdb-0.75/TARGETS
+--- cdb-0.75-orig/TARGETS 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/TARGETS 2009-01-16 19:52:06.000000000 +0100
+@@ -1,6 +1,5 @@
+ load
+ compile
+-uint32.h
+ cdbget.o
+ systype
+ makelib
+diff -Naur cdb-0.75-orig/uint32.h cdb-0.75/uint32.h
+--- cdb-0.75-orig/uint32.h 1970-01-01 01:00:00.000000000 +0100
++++ cdb-0.75/uint32.h 2009-01-16 19:46:17.000000000 +0100
+@@ -0,0 +1,11 @@
++#ifndef UINT32_H
++#define UINT32_H
++
++#include <stdint.h>
++
++extern void uint32_pack(char *,uint32_t);
++extern void uint32_pack_big(char *,uint32_t);
++extern void uint32_unpack(char *,uint32_t *);
++extern void uint32_unpack_big(char *,uint32_t *);
++
++#endif
+diff -Naur cdb-0.75-orig/uint32.h1 cdb-0.75/uint32.h1
+--- cdb-0.75-orig/uint32.h1 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/uint32.h1 1970-01-01 01:00:00.000000000 +0100
+@@ -1,11 +0,0 @@
+-#ifndef UINT32_H
+-#define UINT32_H
+-
+-typedef unsigned int uint32;
+-
+-extern void uint32_pack(char *,uint32);
+-extern void uint32_pack_big(char *,uint32);
+-extern void uint32_unpack(char *,uint32 *);
+-extern void uint32_unpack_big(char *,uint32 *);
+-
+-#endif
+diff -Naur cdb-0.75-orig/uint32.h2 cdb-0.75/uint32.h2
+--- cdb-0.75-orig/uint32.h2 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/uint32.h2 1970-01-01 01:00:00.000000000 +0100
+@@ -1,11 +0,0 @@
+-#ifndef UINT32_H
+-#define UINT32_H
+-
+-typedef unsigned long uint32;
+-
+-extern void uint32_pack(char *,uint32);
+-extern void uint32_pack_big(char *,uint32);
+-extern void uint32_unpack(char *,uint32 *);
+-extern void uint32_unpack_big(char *,uint32 *);
+-
+-#endif
+diff -Naur cdb-0.75-orig/uint32_pack.c cdb-0.75/uint32_pack.c
+--- cdb-0.75-orig/uint32_pack.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/uint32_pack.c 2009-01-16 19:46:17.000000000 +0100
+@@ -1,6 +1,6 @@
+ #include "uint32.h"
+
+-void uint32_pack(char s[4],uint32 u)
++void uint32_pack(char s[4],uint32_t u)
+ {
+ s[0] = u & 255;
+ u >>= 8;
+@@ -10,7 +10,7 @@
+ s[3] = u >> 8;
+ }
+
+-void uint32_pack_big(char s[4],uint32 u)
++void uint32_pack_big(char s[4],uint32_t u)
+ {
+ s[3] = u & 255;
+ u >>= 8;
+diff -Naur cdb-0.75-orig/uint32_unpack.c cdb-0.75/uint32_unpack.c
+--- cdb-0.75-orig/uint32_unpack.c 2009-01-16 19:38:41.000000000 +0100
++++ cdb-0.75/uint32_unpack.c 2009-01-16 19:46:17.000000000 +0100
+@@ -1,8 +1,8 @@
+ #include "uint32.h"
+
+-void uint32_unpack(char s[4],uint32 *u)
++void uint32_unpack(char s[4],uint32_t *u)
+ {
+- uint32 result;
++ uint32_t result;
+
+ result = (unsigned char) s[3];
+ result <<= 8;
+@@ -15,9 +15,9 @@
+ *u = result;
+ }
+
+-void uint32_unpack_big(char s[4],uint32 *u)
++void uint32_unpack_big(char s[4],uint32_t *u)
+ {
+- uint32 result;
++ uint32_t result;
+
+ result = (unsigned char) s[0];
+ result <<= 8;
diff --git a/dev-db/cdb/metadata.xml b/dev-db/cdb/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/dev-db/cdb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>