summaryrefslogtreecommitdiff
path: root/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild')
-rw-r--r--dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild b/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
index cf1793d314a8..5fd90979b8e5 100644
--- a/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
+++ b/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_P=${PN/f/F}-$(ver_rs 4 '-')
-inherit autotools flag-o-matic
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Relational database offering many ANSI SQL:2003 and some SQL:2008 features"
HOMEPAGE="https://www.firebirdsql.org/"
@@ -91,6 +91,10 @@ src_prepare() {
-e 's:ISQL :FBSQL :w /dev/stdout' \
src/msgs/messages2.sql | wc -l)" "6" "src/msgs/messages2.sql" # 6 lines
+ # bug #917662, bug #924659
+ filter-lto
+ append-flags -fno-strict-aliasing $(test-flags-CXX -fno-lifetime-dse)
+
# use gentoo's CXXFLAGS instead of whatever firebird decided on
# doesn't replace all firebird's CXXFLAGS, but at least this is last,
# so it can do some overrides