summaryrefslogtreecommitdiff
path: root/dev-db/libzdb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/libzdb')
-rw-r--r--dev-db/libzdb/Manifest1
-rw-r--r--dev-db/libzdb/libzdb-3.1.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/dev-db/libzdb/Manifest b/dev-db/libzdb/Manifest
index 6f37fd2ba274..767223ea35a0 100644
--- a/dev-db/libzdb/Manifest
+++ b/dev-db/libzdb/Manifest
@@ -1,4 +1,3 @@
DIST libzdb-3.1.tar.gz 720162 BLAKE2B 2ad8ede7e2a1c0ee831ba546b7756d2688bcde83b537e812c12ab3d42d6bdc13526778ae68b61584a52569f0b42fbeb8462efe379821295d855f585ae3420df4 SHA512 7cf24ccf0f0a938955d8b54af2c6eca8a8f700737beafde9e824129f324511e06adbc11a3fdbd6ad6d9b902fdae6f7caab4e5c1c594d2211be314e3a24c697f3
EBUILD libzdb-3.1-r1.ebuild 1987 BLAKE2B 7747fd2a24c9f45fbd2713d931a41368369964635466442b452af6a1ea38e1b187d26a424981b76da1a9796dd45a94d00fd3f79a2b43e6f9e855e3b0c6b2b719 SHA512 735b7ed0579a6cdc95dec473f6fc0d15891e51d2068ccedec1188b163a3afa285603a32f68352df88c7cd3f5bc9dc15da6cfb41321b4a2b09efd1231e2dfb0f0
-EBUILD libzdb-3.1.ebuild 1894 BLAKE2B 6247c8d2295cccecb214a306688027b72391e83507ee16870119cd9c7b7c059bbffd07adc62c21ce0a0387c9a7dce5a6df4cba93d98da21507b9ac456e434b95 SHA512 53b3808f028b78f96c05b8d59f7d5d1301bda641afbb0c8f41a36ec28de807d00c0be02f51841602bdfb2d05cd0a79682916d4d82096332265ebbaf4758badd0
MISC metadata.xml 252 BLAKE2B 607ece46067f5be04418014fa63f92ad521ce98dcd952feb4fcd1bcfcb16fd520bddb62e7f6e14486a7f45a2505cc258067adc1017af98ba9e69a78244bc62a5 SHA512 e7da72c861777d74f6459375f6f43e39f9e4dda779352c3e8942fcd658dcce6f995f016e34a74b331533f1815fba3faa9af024956a804f38a411990878e4bad6
diff --git a/dev-db/libzdb/libzdb-3.1.ebuild b/dev-db/libzdb/libzdb-3.1.ebuild
deleted file mode 100644
index caa64e3ef38f..000000000000
--- a/dev-db/libzdb/libzdb-3.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A thread safe high level multi-database connection pool library"
-HOMEPAGE="http://www.tildeslash.com/libzdb/"
-SRC_URI="http://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc mysql postgres +sqlite ssl static-libs"
-REQUIRED_USE=" || ( postgres mysql sqlite )"
-
-RESTRICT=test
-
-RDEPEND="mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- sed -i -e "s|&& ./pool||g" test/Makefile.in || die
-}
-
-src_configure() {
- ## TODO: check what --enable-optimized actually does
- ## TODO: find someone with oracle db to add oci8 support
- myconf=""
- # enable default hidden visibility
- myconf="${myconf} --enable-protected"
-
- if use sqlite; then
- myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
- else
- myconf="${myconf} --without-sqlite"
- fi
-
- if use mysql; then
- myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
- else
- myconf="${myconf} --without-mysql"
- fi
-
- if use postgres; then
- myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
- else
- myconf="${myconf} --without-postgresql"
- fi
-
- econf \
- $(use_enable debug profiling) \
- $(use_enable static-libs static) \
- $(use_enable ssl openssl) \
- --without-oci \
- ${myconf}
-}
-
-src_compile() {
- default_src_compile
- if use doc; then
- emake doc
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # the --disable-static flag only skips .a
- use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
-
- dodoc AUTHORS CHANGES README
- if use doc;then
- dohtml -r "${S}/doc/api-docs"/*
- fi
-}
-
-src_test() {
- emake verify
-}