summaryrefslogtreecommitdiff
path: root/dev-db/mtop
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mtop')
-rw-r--r--dev-db/mtop/Manifest4
-rw-r--r--dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch12
-rw-r--r--dev-db/mtop/metadata.xml11
-rw-r--r--dev-db/mtop/mtop-0.6.6-r3.ebuild33
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-db/mtop/Manifest b/dev-db/mtop/Manifest
new file mode 100644
index 000000000000..68c6d029e5bc
--- /dev/null
+++ b/dev-db/mtop/Manifest
@@ -0,0 +1,4 @@
+AUX mtop-0.6.6-globalstatusfix.patch 623 BLAKE2B b64d931cb283da63d6aaf8affa21905c9289c681bd24a0ff5c690123e023e45cca9506a3d750a5871c07598b8672da504a1d5f7427ec9419005c05e0e9f3dffa SHA512 848de7bda1a79bbe51b139b149720872a57e4fa12161fc822e69f393586817acbe14571841df5d327297546b4ad3a2725b7cd8d1815f80ffc0a2dfcbb9ea5005
+DIST mtop-0.6.6.tar.gz 48161 BLAKE2B 6e1716d3b4b1617b1b78ae0bac3e363b17264bccd65a0b5831a7cf574fbf7826f5041829084c5af614d1f922eb368e33db8d31f0b12103d18661e7aaa6681616 SHA512 9befb1d44ef537c4abe0246ebbf20019499875d7e8efeac2fd1cf068dc577c2809bb0333ebf633982852446a0160d73ccfa0006dcfa42f7d95bbbf765f12ce17
+EBUILD mtop-0.6.6-r3.ebuild 689 BLAKE2B ea6a6304040b14c18ab9ec2b94e5510a46ff6ab19b2eda1f75b8b423de4192ad2965d74bf5810a28e03f89baa01fd4580153ec205faf9ab934d16a750faa63ed SHA512 fe88f9bc1fd7f454183317ddaf0a02929d124ebac5dae2ee0deee4d777e8ae42ad4817d655857aec45c6b72e6c783b7ec0a2407afad98923c2aeec648d6500c6
+MISC metadata.xml 317 BLAKE2B f81f748d63aadbfa6484a46c1f4506f163c547c8fb229d67e4a26e162ec8e0e2a43946bf06ab707e2ebc9db82b0e70763bb06e8c43a194f272d384898fcf8a77 SHA512 20fab32a55c5ac7cdec57d533376c1dc642e30e75e2d9289f815293e734b9e21c1047cf28bba9f75808a9f2c77992ca651ecd3a244849479ad43bfa7fe02ec8c
diff --git a/dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch b/dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch
new file mode 100644
index 000000000000..1d10acc42a99
--- /dev/null
+++ b/dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch
@@ -0,0 +1,12 @@
+diff -ur mtop-0.6.6/work/mtop-0.6.6/mtop.PL mtop-0.6.6-r1/work/mtop-0.6.6/mtop.PL
+--- mtop-0.6.6/work/mtop-0.6.6/mtop.PL 2004-09-13 00:22:03.000000000 +0200
++++ mtop-0.6.6-r1/work/mtop-0.6.6/mtop.PL 2009-12-08 15:04:56.000000000 +0100
+@@ -568,7 +568,7 @@
+ die "Unable to connect to mysql [", $DBI::errstr, "]\n";
+
+ my $st_procs = $dbh->prepare("show full processlist");
+-my $st_status = $dbh->prepare("show status");
++my $st_status = $dbh->prepare("show global status");
+ my $st_kill = $dbh->prepare("kill ?");
+ my $st_flush = $dbh->prepare("flush status");
+ my $st_vars = $dbh->prepare("show variables");
diff --git a/dev-db/mtop/metadata.xml b/dev-db/mtop/metadata.xml
new file mode 100644
index 000000000000..b42d9d75d4c9
--- /dev/null
+++ b/dev-db/mtop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>mysql-bugs@gentoo.org</email>
+ <name>MySQL</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mtop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/mtop/mtop-0.6.6-r3.ebuild b/dev-db/mtop/mtop-0.6.6-r3.ebuild
new file mode 100644
index 000000000000..9a6df615b6d3
--- /dev/null
+++ b/dev-db/mtop/mtop-0.6.6-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit perl-module
+
+DESCRIPTION="Mysql top monitors a MySQL server"
+HOMEPAGE="http://mtop.sourceforge.net"
+SRC_URI="mirror://sourceforge/mtop/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="dev-perl/Curses
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ virtual/perl-libnet"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/mtop-0.6.6-globalstatusfix.patch )
+DOCS=( ChangeLog README README.devel )
+
+warnmsg() {
+ einfo "Upstream no longer maintains mtop. You should consider dev-db/mytop instead."
+}
+
+pkg_postinst() {
+ warnmsg
+}
+
+pkg_preinst() {
+ warnmsg
+}