summaryrefslogtreecommitdiff
path: root/dev-db/ocp/ocp-0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/ocp/ocp-0.2-r1.ebuild')
-rw-r--r--dev-db/ocp/ocp-0.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/ocp/ocp-0.2-r1.ebuild b/dev-db/ocp/ocp-0.2-r1.ebuild
new file mode 100644
index 000000000000..f53cafed6893
--- /dev/null
+++ b/dev-db/ocp/ocp-0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient[sdk]
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+ default
+}