summaryrefslogtreecommitdiff
path: root/dev-db/plr
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/plr')
-rw-r--r--dev-db/plr/Manifest3
-rw-r--r--dev-db/plr/metadata.xml23
-rw-r--r--dev-db/plr/plr-8.3.0.17.ebuild69
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
new file mode 100644
index 000000000000..cb0d09a9ab4e
--- /dev/null
+++ b/dev-db/plr/Manifest
@@ -0,0 +1,3 @@
+DIST plr-8.3.0.17.tar.gz 74017 BLAKE2B 314b4cfa2c3ca8ed31e80a72233a6dc8cdb9f3811dad6e9f3eb5147c17cdf5a039436598b0fc2b30c6702b02dd3cb2da33543764aee3199c6864aae22be875ce SHA512 d7080c62349d1dcdd17008a7be3643b54678e0f66bf721068df73057394496d025c4fe01e52945c3acf9cc21eb90241512667772ef3fe519a3c9081efe92dd40
+EBUILD plr-8.3.0.17.ebuild 1703 BLAKE2B 9bd366ade594cc4a79cfa74a66c55cce8072dd6aed04ff28c68880d68c54ef5187c9221ad22c87c832e8eb75501bef68ae1c466418b1cb1606561c76603c8e79 SHA512 b7131973bcecc6c8dcf617b82d3b0da9e76ec014d6dc8fb577270016dfff6f9dbddd5e1b1bf3fda51c0447e12e44055d43f229a2d3daa752ee522a19177b9927
+MISC metadata.xml 800 BLAKE2B b12bbd609b12d63306bdc9af15f788d91847ae4a8960b26f92d1d8ca000291a047424f2632d22798855a1b61cad2a9d46095f214ba9f7c41616c5a90ee4dddbf SHA512 23728ed4ec8bd27a2ccf2081f4b0ddd2d8ecf47fd9c44f999406c8f3bd7c2f86545dbf837c99dc0e9ef9100b2028a9ae3f10a6d60a21bafbbc7231c445a9c85a
diff --git a/dev-db/plr/metadata.xml b/dev-db/plr/metadata.xml
new file mode 100644
index 000000000000..a604889e04b6
--- /dev/null
+++ b/dev-db/plr/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>axs@gentoo.org</email>
+ <name>Ian Stakenvicius</name>
+</maintainer>
+<longdescription>
+An extension for postgresql databases to allow direct usage of <pkg>dev-lang/R</pkg>
+in SQL queries and database functions
+</longdescription>
+</pkgmetadata>
diff --git a/dev-db/plr/plr-8.3.0.17.ebuild b/dev-db/plr/plr-8.3.0.17.ebuild
new file mode 100644
index 000000000000..355b915ed2db
--- /dev/null
+++ b/dev-db/plr/plr-8.3.0.17.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} 10 )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="R language extension for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/R
+ ${POSTGRES_DEP}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+S=${WORKDIR}/contrib/${PN}
+
+src_unpack() {
+ unpack ${A}
+ # the build system wants 'contrib' to be part of the path
+ mkdir -p "${WORKDIR}/contrib"
+ mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}"
+}
+
+src_prepare() {
+ local BUILD_DIR="${S}"
+ postgres-multi_src_prepare
+}
+
+src_compile() {
+ pg_src_compile() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${SYSROOT}${EPREFIX}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1
+ }
+ postgres-multi_foreach pg_src_compile
+}
+
+src_install() {
+ pg_src_install() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${SYSROOT}${EPREFIX}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1 DESTDIR="${D}" install
+ }
+ postgres-multi_foreach pg_src_install
+}
+
+pkg_postinst() {
+ elog "The plr extension needs to be explicitly added (or 'created') on each database"
+ elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
+ elog "with the proprietary SQL statement:"
+ elog
+ elog "\tCREATE EXTENSION plr;"
+ elog
+ elog "For more info on how to add PL/R to your postgresql database(s), please visit"
+ elog "http://www.joeconway.com/doc/plr-install.html"
+}