summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-11.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-11.12.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-11.12.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-db/postgresql/postgresql-11.12.ebuild b/dev-db/postgresql/postgresql-11.12.ebuild
index 354f7ceacec8..07aed06687cf 100644
--- a/dev-db/postgresql/postgresql-11.12.ebuild
+++ b/dev-db/postgresql/postgresql-11.12.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
@@ -388,7 +388,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi