summaryrefslogtreecommitdiff
path: root/dev-db/recutils
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/recutils')
-rw-r--r--dev-db/recutils/Manifest3
-rw-r--r--dev-db/recutils/files/recutils-1.9-add-const.patch14
-rw-r--r--dev-db/recutils/recutils-1.9-r1.ebuild (renamed from dev-db/recutils/recutils-1.9.ebuild)10
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-db/recutils/Manifest b/dev-db/recutils/Manifest
index adf43a3dc33a..903f034c5c3f 100644
--- a/dev-db/recutils/Manifest
+++ b/dev-db/recutils/Manifest
@@ -8,6 +8,7 @@ AUX 1.9/0007-configure.ac-modernise.patch 3064 BLAKE2B a48d78f15b9da375453a94a60
AUX 1.9/0008-configure.ac-call-PKG_PROG_PKG_CONFIG-unconditionall.patch 1200 BLAKE2B eda53eee3379987fb93df87c028d06dc664fd2609b6130babac56ae096dbc0b4f6201fffcfa272ddcc13ce53c8a9a9925e2aa4bb3bc0f1dc95394d935c8e3aa0 SHA512 442b4d7b07279c641a19b74d4a552f1aa12ce769ca18ce7d8462415d91f0d412025060c9bea943007f676b0d9d535234d152ff8ea4877b221426dc1b55edc3a7
AUX 1.9/0009-Port-to-newer-mdbutils-0.9.0.patch 2173 BLAKE2B 27213a8fddc10ad9f075f80591d97699bcdecffc9274d4f6e6746b1456f124d9dcb743fae4252fdd245e11005ba0da510bdf1141e2d848db3ef7f219879cb93c SHA512 d75196de27d46489553230c7d21ab775a0dded704209adaef87df4ef8a62ef7322a98116ad6d0d869dc4ad12e11484b8d2da42e2a36f6d3c8153898fa8b3fd0c
AUX 1.9/0010-configure.ac-use-pkg-config-to-find-curl.patch 1443 BLAKE2B c99a0d501273067f40552c8be3adfce22a4ee7f88f2a3f858eb52219811c703c97e31e106541d3c7513c4bdda02b8491c7b1b91ae24a6f43bcaa231de8688b40 SHA512 31842f8439778f45b72971c4a9a634e58d1c7424d1777f43d2dafd3ae122f04d6dcccf37521974e6ea99f58e18e6e5b35190fceba7e0266655f225d2908be00b
+AUX recutils-1.9-add-const.patch 487 BLAKE2B eec770635e542e7e85cd0c7ea57d3e4301996fcdedb55f2cae05394a84438c3a5fa6e2581c6867d2df836f2cb45a3c2739fe20f52185d183166a147720fdb560 SHA512 17f6b273790b8645d8aa90ef6ae974563d1db3a0b3836a9247bb39af960e0ab90ea024425d7f6b45b41bf6dc0256002a9322912020aa03357cea722119ff2e70
DIST recutils-1.9.tar.gz 2759999 BLAKE2B 839dbcd36e7fe0ececbf3ef3a1b842890e876c6feda2bc003c921c53eba83b70f38baa5a536962253eec5b06eed29c6e301751d7b6586f0ef0c5ea35d94a44d7 SHA512 775b3b8925a4e5c6f04c6376291b966bdc271f172be2bca06b1f02155ecba12d916c22219f85fe0393f7f9f200f3788ab5fa5d522da2b84b2a0c0ec198318809
-EBUILD recutils-1.9.ebuild 1047 BLAKE2B 4248100bffedd08c52928a24797a44e2e67bb84948465d1bb66cb4cb0e50315681af8479696370bf6a854108ed6855d47e6cc238fee1ac407c968fe8bf5fa85d SHA512 513f3f984bfbd25ccaf83c72673c4429dd0ec5700f52817da48a8de80992fe258b6fcf2fa40b7cc466d30b442fa3afd30b01773df73b49629c43691758b698ba
+EBUILD recutils-1.9-r1.ebuild 1205 BLAKE2B 3f16a4bbc4b1dd0a7712e147705359430777fe1b3de46cdd12ac6ebd94b55ae803a77bed49d689307f82f60999670b2c711d1ebaf3724c0d98ebcd8ac69c6e47 SHA512 fca1f74741cf168d14a268452ab8960ba021f900381aa1d66f3824406a012f1b0d9f6bc229d96d914e6f32a2aeaac1bb1e6b094ba183965e95a58241c4297688
MISC metadata.xml 624 BLAKE2B 99f308873f7c982a3b881053f9fec8a459ccb9003cec4d97364a73fee13cbe46b711d4e981ef0dc9c6bd24eaf8bd07a3d5fdc864a83ab4948da0c2d2cbe57745 SHA512 41bc9720c4d104c5502c9cfe197ac15526835d6c2b2ffbef34d2415ceaef6d43e9295f71c4b6a92ba89c88a210d79e6e70332071a9c083ffdd073d9a4563b1f3
diff --git a/dev-db/recutils/files/recutils-1.9-add-const.patch b/dev-db/recutils/files/recutils-1.9-add-const.patch
new file mode 100644
index 000000000000..b8c14845d11e
--- /dev/null
+++ b/dev-db/recutils/files/recutils-1.9-add-const.patch
@@ -0,0 +1,14 @@
+Cast bash-generated argv from char ** to const char ** so it would be of the same
+type argv was declared
+https://bugs.gentoo.org/941542
+--- a/bash/testrec.c
++++ b/bash/testrec.c
+@@ -60,7 +60,7 @@
+
+ /* Get arguments and verify them. */
+
+- argv = make_builtin_argv (list, &argc);
++ argv = (const char**)make_builtin_argv (list, &argc);
+ if ((argc != 3)
+ || ((strcmp (argv[0], "[%") == 0) && ((strlen (argv[2]) == 2) && ((argv[2][0] != '%') || (argv[2][1] != ']')))))
+ {
diff --git a/dev-db/recutils/recutils-1.9.ebuild b/dev-db/recutils/recutils-1.9-r1.ebuild
index cff0821ae74e..df600fd416d6 100644
--- a/dev-db/recutils/recutils-1.9.ebuild
+++ b/dev-db/recutils/recutils-1.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -37,6 +37,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PV}
+ "${FILESDIR}"/${P}-add-const.patch
)
src_prepare() {
@@ -63,3 +64,10 @@ src_test() {
# tests have parallel issues
emake -j1 check
}
+
+src_install() {
+ default
+
+ # Remove unneeded .la files (Bug #941097)
+ find "${ED}" -name '*.la' -type f -delete || die
+}