summaryrefslogtreecommitdiff
path: root/dev-db/soci
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/soci')
-rw-r--r--dev-db/soci/Manifest3
-rw-r--r--dev-db/soci/metadata.xml11
-rw-r--r--dev-db/soci/soci-3.2.3.ebuild50
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/soci/Manifest b/dev-db/soci/Manifest
new file mode 100644
index 000000000000..d6300739bed3
--- /dev/null
+++ b/dev-db/soci/Manifest
@@ -0,0 +1,3 @@
+DIST soci-3.2.3.zip 508929 BLAKE2B e1a83172391508506744b18ac0b18d69bec34bfbd31d9156b2cb786cdb7cdd8a99ace21d1286a2c4432ba18e18dedc4f390075a25a30fa2e45f36d802661ddb2 SHA512 dd9b7eaf535502e3230eada4d4d019963d2c9cf59b69fff5d466b4fc00976fa08f7b0199a0e4564a0395d0d30095b97aa1d613dfbaa329feb077ece3b0efacdf
+EBUILD soci-3.2.3.ebuild 1235 BLAKE2B ce606fe16c860275ac1eb0d9e165c3bd6cf57ada31fc1698b30854ff9f3dfc6ffbbf4ec523466c4d6f06dd79bbaa800aef49885679bdd55dd6b89121f4868d32 SHA512 331534dc170ae1cf0d986069bca6dea98b4e97868c155972ae2ba28f15499bcf26af9abf15549a5b39102f592cc535be969f24699f1f3cb6f39c4b465211b1cb
+MISC metadata.xml 343 BLAKE2B 7257e5f29bfd60e7231870e28d745ea123af37110ddf907c7a4dedb4e984a330e62f02f61b59075ee7eb30a77f89e5b3edc72070a18158fa5cbf6e5bb3596908 SHA512 a3441b5c5f7127af874a08bc9e05dd95f1594167906383c44fcfb9620e52fdabdd90b23c2cbc6f082699150b1593b4600f7a9eae54c799f501b95ca9022d83c7
diff --git a/dev-db/soci/metadata.xml b/dev-db/soci/metadata.xml
new file mode 100644
index 000000000000..3f843d86929c
--- /dev/null
+++ b/dev-db/soci/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="boost">Enable boost support</flag>
+ <flag name="empty">Build the sample backend called Empty</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">soci</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/soci/soci-3.2.3.ebuild b/dev-db/soci/soci-3.2.3.ebuild
new file mode 100644
index 000000000000..f31882f3e189
--- /dev/null
+++ b/dev-db/soci/soci-3.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Makes the illusion of embedding SQL queries in the regular C++ code"
+HOMEPAGE="http://soci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite static-libs test"
+
+RDEPEND="
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${RDEPEND}
+ boost? ( dev-libs/boost )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_BOOST=$(usex boost)
+ -DSOCI_EMPTY=$(usex empty)
+ -DWITH_FIREBIRD=$(usex firebird)
+ -DWITH_MYSQL=$(usex mysql)
+ -DWITH_ODBC=$(usex odbc)
+ -DWITH_ORACLE=$(usex oracle)
+ -DWITH_POSTGRESQL=$(usex postgres)
+ -DWITH_SQLITE3=$(usex sqlite)
+ -DSOCI_STATIC=$(usex static-libs)
+ -DSOCI_TESTS=$(usex test)
+ -DWITH_DB2=OFF
+ )
+ #use MYCMAKEARGS if you want enable IBM DB2 support
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ cmake-utils_src_install
+}