summaryrefslogtreecommitdiff
path: root/dev-debug/strace/strace-6.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/strace/strace-6.9.ebuild')
-rw-r--r--dev-debug/strace/strace-6.9.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-debug/strace/strace-6.9.ebuild b/dev-debug/strace/strace-6.9.ebuild
index b1c0ddf9a697..571c162459fb 100644
--- a/dev-debug/strace/strace-6.9.ebuild
+++ b/dev-debug/strace/strace-6.9.ebuild
@@ -40,7 +40,6 @@ LIB_DEPEND="
DEPEND="
static? ( ${LIB_DEPEND} )
aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
"
RDEPEND="
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
@@ -87,11 +86,15 @@ src_configure() {
# Don't require mpers support on non-multilib systems. #649560
--enable-mpers=check
+ # We don't want to pin to exact linux-headers versions (bug #950309)
+ --enable-bundled=yes
+
$(use_enable static)
$(use_with unwind libunwind)
$(use_with elfutils libdw)
$(use_with selinux libselinux)
)
+
econf "${myeconfargs[@]}"
}