summaryrefslogtreecommitdiff
path: root/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
index 3e3f048ac1ab..5b132bbcc2c9 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+SDK_SLOT="$(ver_cut 1-2)"
+RUNTIME_SLOT="${SDK_SLOT}.14"
+
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
https://github.com/dotnet/dotnet/"
@@ -22,17 +25,25 @@ arm64? (
"
S="${WORKDIR}"
-SDK_SLOT="$(ver_cut 1-2)"
-RUNTIME_SLOT="${SDK_SLOT}.14"
-SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-
LICENSE="MIT"
+SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
KEYWORDS="amd64 arm arm64"
# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
# bug https://bugs.gentoo.org/923430
RESTRICT="splitdebug strip"
+CURRENT_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
+"
+EXTRA_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-6.0.25
+"
+NUGETS_DEPEND="
+ ${CURRENT_NUGETS_DEPEND}
+ ${EXTRA_NUGETS_DEPEND}
+"
+
RDEPEND="
app-crypt/mit-krb5:0/0
dev-libs/icu
@@ -46,8 +57,7 @@ IDEPEND="
app-eselect/eselect-dotnet
"
PDEPEND="
- ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
- ~dev-dotnet/dotnet-runtime-nugets-6.0.25
+ ${NUGETS_DEPEND}
"
QA_PREBUILT="*"