summaryrefslogtreecommitdiff
path: root/dev-embedded/arduino-builder
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/arduino-builder')
-rw-r--r--dev-embedded/arduino-builder/Manifest1
-rw-r--r--dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-embedded/arduino-builder/Manifest b/dev-embedded/arduino-builder/Manifest
index 89db73dfa06a..c6f040e7ae12 100644
--- a/dev-embedded/arduino-builder/Manifest
+++ b/dev-embedded/arduino-builder/Manifest
@@ -19,5 +19,4 @@ DIST github.com-jstemmer-go-junit-report-833f8ea2b99d36d5f018698333834f3df200a0c
DIST github.com-stretchr-testify-1661650f989674e3e5bcdcb805536e5d31481526.tar.gz 81099 BLAKE2B 592a7c114b01bc5b1982135f310aa8619c2888ac36ccb5d876a38655a13f7dc4d468a7a42a44cf9cf69fc7bd6769a9ba010b48089d5ce866dcd564e20487e04a SHA512 f10255b0f47237c7583626a3bb213ca67d0db92c2a1531cc31dac089cdb13139b01647809503313a26f3e53a64a98cebc3bf9c4e1bd1ed975d9b81aa516ab5af
EBUILD arduino-builder-1.3.25.ebuild 2824 BLAKE2B b8d42a6e5086df92dc85a3714720140b0aa99ece6035d8356565eb0e9235d4da65206a38559078341576bb5a3dcb77b53dfad115b1f42ce54d132771867c7709 SHA512 0d6a2360afc615db3c1a43600cbe70cc9348035a170727f3ce7097cd7630239a376a095b2b4763c3e9f11d8b915be848d5387d6ae7d29eccaeadbb46e02242bc
EBUILD arduino-builder-1.4.1-r1.ebuild 2648 BLAKE2B 0066af35c8917dfb8eaf4eec2d272d534301c7ba725d3d75aa79bdc5faa40584961c7dd87b9a463cd27654bb3f9795d3f5c9f1df883d9c6190c4efd6abc99a22 SHA512 87987c3acf7ac7cea649cc21676308dea88cba82e9e6f867a3fcb517244e3a53c718724c22ae9784f8e169334ea1f64604cb931e60e3093b178c6762e6ca5dc4
-EBUILD arduino-builder-1.4.1.ebuild 2478 BLAKE2B 85a284b161b9e98260c52fd5338db7c8f3afe1063f00306fa73e1ef7f0ce2cbf0cdfc07ec75729d89b8ceed995671dc96c62c0c90581edccb38a52ae367b1533 SHA512 0deb62c9ebaa1089f0b2e021e871a29a2994edc167a6f9cdb01ddb9fab38f2bd8a640759627adfa2c5d068b47afd0d6ac77520c5c40f6245aaaed0fef33d7233
MISC metadata.xml 339 BLAKE2B 8353146b638f77f9846c37e1717f19e9d3eff24a88a8299bb43d6118e47c5159a53ed8612681f5f849269a8d250d99b9dc57030452d96ed81975196b3faedfb1 SHA512 3a107172d306efee35994af117181d4a08388883d4efeb48dd270f8a711deae39d68e1bd38423e0a71d91f708d4c1877d300ed4823e43fda8a924bd98b8f37c7
diff --git a/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild b/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild
deleted file mode 100644
index 078347f52348..000000000000
--- a/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN="github.com/arduino/arduino-builder/..."
-
-EGO_VENDOR=(
- "github.com/arduino/go-properties-map ad37f0cfeff29fadeabe6b2f7f852d8db1fb5c41"
- "github.com/arduino/go-timeutils d1dd9e313b1bfede35fe0bbf46d612e16a50e04e"
- "github.com/arduino/go-paths-helper 751652ddd9f0a98650e681673c2c73937002e889"
- "github.com/fsnotify/fsnotify c2828203cd70a50dcccfb2761f8b1f8ceef9a8e9"
- "github.com/go-errors/errors a41850380601eeb43f4350f7d17c6bbd8944aaf8"
- "github.com/golang/protobuf aa810b61a9c79d51363740d207bb46cf8e620ed5"
- "github.com/jstemmer/go-junit-report 833f8ea2b99d36d5f018698333834f3df200a0c2"
- "github.com/stretchr/testify 1661650f989674e3e5bcdcb805536e5d31481526"
- "google.golang.org/grpc 8dea3dc473e90c8179e519d91302d0597c0ca1d1 github.com/grpc/grpc-go"
- "google.golang.org/genproto af9cb2a35e7f169ec875002c1829c9b315cddc04 github.com/google/go-genproto"
-)
-
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="A command line tool for compiling Arduino sketches"
-HOMEPAGE="https://github.com/arduino/arduino-builder"
-SRC_URI="https://github.com/arduino/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_VENDOR_URI}"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="sys-devel/crossdev
- dev-embedded/avrdude
- dev-embedded/arduino-ctags"
-
-DEPEND=">=dev-lang/go-1.9.2
- dev-go/go-net
- dev-go/go-text"
-
-PATCHES=(
- "${FILESDIR}/arduino-builder-1.4.1-platform-paths.patch"
- "${FILESDIR}/arduino-builder-1.4.1-skip-tests.patch"
-)
-
-src_unpack() {
- golang-vcs-snapshot_src_unpack
-}
-
-src_install() {
- # we unfortunately have to copy/paste the contents of golang-build_src_install() here because
- # we *don't* want to call golang_install_pkgs() which installs all static libraries we've
- # built. All we want is to install the final executable.
-
- set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
- echo "$@"
- "$@" || die
-
- # END OF COPY/PASTE
-
- dobin bin/arduino-builder
- # In addition to the binary, we also want to install these two files below. They are needed by
- # the dev-embedded/arduino which copies those files in its "hardware" folder.
- insinto "/usr/share/${PN}"
- cd "src/github.com/arduino/arduino-builder/hardware" || die
- doins "platform.txt"
- doins "platform.keys.rewrite.txt"
-}
-
-pkg_postinst() {
- [ ! -x /usr/bin/avr-gcc ] && ewarn "Missing avr-gcc; you need to crossdev -s4 avr"
-}