summaryrefslogtreecommitdiff
path: root/dev-games
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/Manifest.gzbin5734 -> 5733 bytes
-rw-r--r--dev-games/godot/Manifest3
-rw-r--r--dev-games/godot/files/godot-4.4-scons.patch15
-rw-r--r--dev-games/godot/godot-4.4.ebuild230
4 files changed, 248 insertions, 0 deletions
diff --git a/dev-games/Manifest.gz b/dev-games/Manifest.gz
index 9997acb8201e..005057fa17fc 100644
--- a/dev-games/Manifest.gz
+++ b/dev-games/Manifest.gz
Binary files differ
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index f743ed939b3e..ee9cb41c4c9a 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,5 +1,8 @@
AUX godot-4.3-gcc15.patch 667 BLAKE2B 34e8113b9a343e02768a31f7e28ebbf176c07ca5ba7a67f85869e4ab8cec9f3c34950d76ff329d947bf176afef10ba7e9eddbb95e5e446f092ce99018f38499b SHA512 a61938a3add91ad78527ca5cfda0506067d886c7cf2f320c361c2566d8a9ee8b560792e5e7faa11491659c8fa103c027b30fe90bac4345c13e17b9ae2d9af2ea
AUX godot-4.3-scons.patch 524 BLAKE2B fc62a07a0560a186f2feeb931ea33b4bc5e574a4c08b7de5bfb674365d39fd2592b7e1b392402f28dd110fbe4942295e737b94d4022907eceb9142496f1c2fb6 SHA512 3968cf509462fe26e0c7e5edabb4bc1ba5b51d8353e92679b4c6842a71e003edfaa0b4e7e87fe18af85c8acff834a62c11ecc28ea6b42f6ca6790d18136d6ccf
+AUX godot-4.4-scons.patch 489 BLAKE2B 668209e9a41fce183843fc691889a93263460941a260d9f8e66b6281a0a72d6e81c51f8b23a186b85049b1b364a5ba96d17aa4d1cb6a1a5becd67ac2b8e5b51a SHA512 38692d1da058d32ab96bd3c18130edc85d87c60a7743593bf7f434eb81df024f07cacb745304b67a9892a17ef62af84e3a1b43477233e07a7bf01487c39214af
DIST godot-4.3-stable.tar.xz 29140004 BLAKE2B 0698cf6c8ba853d094c39b461efe998c57a7de0609701e46cca48b17c29eca3da29c8644aa356cff330d1d3ae88048afc2148f5389d57cdfa1dd26784e6d9a44 SHA512 6e1eaba5c3447527ce60d623f7f81cbd90633a5a1ad4c6dd469055a43c8fb9b4807fcd3bae25331294596c2418eb6c0c9db0871c3e1405ddcc7d84e29c39a45b
+DIST godot-4.4-stable.tar.xz 36485332 BLAKE2B 2ffde3c166db9e96e71d3175e9e0026c5eee34c9fe2a40a233ae0383db774d84f9f14142686c9cd8f0ee740fc67ffd15570f6ccd1e790048e24634d2129881f7 SHA512 12c03bb0d3465a8059367602a9628e1028622e220bd8a224713025bb82916d1149525332af1476ab7e5b8239569adad8f4213763807bc9a5efcac26433f35892
EBUILD godot-4.3-r1.ebuild 7207 BLAKE2B 79fe78550e3e66214918c08cc78b9cccee74e8b7901742f62048133c13bdb1892681d5f3314297895c81542c04350c93c6ff29f687dd6189fcf2e9079cc28be4 SHA512 5f59f881965be09436cf4009fbf39c2d1382c9a6dca631aa190d781a33d31ca0ab8ac4687dcf72d2aea1f8015be7a490dd3b72f083aae682cf103bcb3a2abfb2
+EBUILD godot-4.4.ebuild 6555 BLAKE2B d45729b45a5ac3efc5e6784ca25c36057977dc69fc2fbb4e309568c70e37b7e83e05f33cf208943c30335fd599851ec82ff7fa132553502c411fa5d7f8b630a9 SHA512 a1c884af28b15cea36c214fce123541329d5889365222dcbae5a7ce16c8fff5032badfba79ea242e19506cd05a5fd01ae058fc0015b8fb237efd7d9f34f6f15c
MISC metadata.xml 1250 BLAKE2B 3f7e9cb4cd29b2c6a0c46c8d494d16d324fd15ca0eb417d04cf30f7e5015d3224b845683110f57d5592601918c334f0394d7de74f8c1c8524a5123de62b09b8d SHA512 e1b2868193999fad5ec57a41e1af2bd6ee33b5f150ff8b0e6905c8e5af3706bdf0d7bfc813ba1004a293593da62a77b5af474e9d2ee166ac4dc23d0c5edc1228
diff --git a/dev-games/godot/files/godot-4.4-scons.patch b/dev-games/godot/files/godot-4.4-scons.patch
new file mode 100644
index 000000000000..0c1ab346d0e3
--- /dev/null
+++ b/dev-games/godot/files/godot-4.4-scons.patch
@@ -0,0 +1,15 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -274,2 +274,3 @@
+ opts.Add("CC", "C compiler binary")
++opts.Add("AR", "Archiver")
+ opts.Add("LINK", "Linker binary")
+@@ -749,8 +750,2 @@
+ env.Append(CCFLAGS=[f"-ffile-prefix-map={project_path}=."])
+- else:
+- if methods.is_apple_clang(env):
+- # Apple Clang, its linker doesn't like -s.
+- env.Append(LINKFLAGS=["-Wl,-S", "-Wl,-x", "-Wl,-dead_strip"])
+- else:
+- env.Append(LINKFLAGS=["-s"])
+
diff --git a/dev-games/godot/godot-4.4.ebuild b/dev-games/godot/godot-4.4.ebuild
new file mode 100644
index 000000000000..522b758d8aeb
--- /dev/null
+++ b/dev-games/godot/godot-4.4.ebuild
@@ -0,0 +1,230 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit desktop python-any-r1 flag-o-matic scons-utils
+inherit shell-completion toolchain-funcs xdg
+
+DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
+HOMEPAGE="https://godotengine.org/"
+SRC_URI="
+ https://downloads.tuxfamily.org/godotengine/${PV}/${P}-stable.tar.xz
+ https://github.com/godotengine/godot/releases/download/${PV}-stable/${P}-stable.tar.xz
+"
+S=${WORKDIR}/${P}-stable
+
+LICENSE="
+ MIT
+ Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
+ gui? ( CC-BY-4.0 ) tools? ( OFL-1.1 )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+# Enable roughly same as upstream by default so it works as expected,
+# except raycast (tools-only heavy dependency), and deprecated.
+IUSE="
+ alsa +dbus debug deprecated +fontconfig +gui pulseaudio raycast
+ speech test +theora +tools +udev +upnp +vulkan wayland +webp
+"
+REQUIRED_USE="wayland? ( gui )"
+# TODO: tests still need more figuring out
+RESTRICT="test"
+
+# dlopen: libglvnd
+RDEPEND="
+ app-arch/brotli:=
+ app-arch/zstd:=
+ dev-games/recastnavigation:=
+ dev-libs/icu:=
+ dev-libs/libpcre2:=[pcre32]
+ media-libs/freetype[brotli,harfbuzz]
+ media-libs/harfbuzz:=[icu]
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libvorbis
+ net-libs/mbedtls:3=
+ net-libs/wslay
+ sys-libs/zlib:=
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( sys-apps/dbus )
+ fontconfig? ( media-libs/fontconfig )
+ gui? (
+ media-libs/libglvnd
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libxkbcommon
+ tools? ( raycast? ( media-libs/embree:4 ) )
+ vulkan? ( media-libs/vulkan-loader[X,wayland?] )
+ )
+ pulseaudio? ( media-libs/libpulse )
+ speech? ( app-accessibility/speech-dispatcher )
+ theora? ( media-libs/libtheora )
+ tools? ( app-misc/ca-certificates )
+ udev? ( virtual/udev )
+ upnp? ( net-libs/miniupnpc:= )
+ wayland? (
+ dev-libs/wayland
+ gui-libs/libdecor
+ )
+ webp? ( media-libs/libwebp:= )
+"
+DEPEND="
+ ${RDEPEND}
+ gui? ( x11-base/xorg-proto )
+ tools? ( test? ( dev-cpp/doctest ) )
+"
+BDEPEND="
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4-scons.patch
+)
+
+src_prepare() {
+ default
+
+ # mbedtls normally has mbedtls.pc, but Gentoo's slotted one is mbedtls3.pc
+ sed -E "/pkg-config/s/(mbedtls|mbedcrypto|mbedx509)/&3/g" \
+ -i platform/linuxbsd/detect.py || die
+
+ sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/linuxbsd/detect.py || die
+
+ # use of builtin_ switches can be messy (see below), delete to be sure
+ local unbundle=(
+ brotli doctest embree freetype graphite harfbuzz icu4c libogg
+ libpng libtheora libvorbis libwebp linuxbsd_headers mbedtls
+ miniupnpc pcre2 recastnavigation volk wslay zlib zstd
+ # certs: unused by generated header, but scons panics if not found
+ )
+ rm -r "${unbundle[@]/#/thirdparty/}" || die
+
+ ln -s -- "${ESYSROOT}"/usr/include/doctest thirdparty/ || die
+}
+
+src_compile() {
+ local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
+
+ filter-lto #921017
+
+ local esconsargs=(
+ AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+
+ progress=no
+ verbose=yes
+
+ use_sowrap=no
+
+ alsa=$(usex alsa)
+ dbus=$(usex dbus)
+ deprecated=$(usex deprecated)
+ execinfo=no # not packaged, disables crash handler if non-glibc
+ fontconfig=$(usex fontconfig)
+ opengl3=$(usex gui)
+ pulseaudio=$(usex pulseaudio)
+ speechd=$(usex speech)
+ udev=$(usex udev)
+ use_volk=no # unnecessary when linking directly to libvulkan
+ vulkan=$(usex gui $(usex vulkan))
+ wayland=$(usex wayland)
+ # TODO: retry to add optional USE=X, wayland support is new
+ # and gui build is not well wired to handle USE="-X wayland" yet
+ x11=$(usex gui)
+
+ system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+
+ # platform/*/detect.py uses builtin_* switches to check if need
+ # to link with system libraries, but many ignore whether the dep
+ # is actually used, so "enable" deleted builtins on disabled deps
+ builtin_brotli=no
+ builtin_certs=no
+ builtin_clipper2=yes # not packaged
+ builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
+ builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
+ builtin_freetype=no
+ builtin_glslang=yes #879111 (for now, may revisit if more stable)
+ builtin_graphite=no
+ builtin_harfbuzz=no
+ builtin_icu4c=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libtheora=$(usex !theora)
+ builtin_libvorbis=no
+ builtin_libwebp=$(usex !webp)
+ builtin_mbedtls=no
+ builtin_miniupnpc=$(usex !upnp)
+ builtin_msdfgen=yes # not wired for unbundling nor packaged
+ builtin_openxr=yes # not packaged
+ builtin_pcre2=no
+ builtin_recastnavigation=no
+ builtin_rvo2=yes # bundled copy has godot-specific changes
+ builtin_wslay=no
+ builtin_xatlas=yes # not wired for unbundling nor packaged
+ builtin_zlib=no
+ builtin_zstd=no
+ # (more is bundled in third_party/ but they lack builtin_* switches)
+
+ # modules with optional dependencies, "possible" to disable more but
+ # gets messy and breaks all sorts of features (expected enabled)
+ module_mono_enabled=no # unhandled
+ # note raycast is only enabled on amd64+arm64 and USE should
+ # be masked for other keywords if added, see raycast/config.py
+ module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
+ module_theora_enabled=$(usex theora)
+ module_upnp_enabled=$(usex upnp)
+ module_webp_enabled=$(usex webp)
+
+ # let *FLAGS handle these
+ debug_symbols=no
+ lto=none
+ optimize=custom
+ use_static_cpp=no
+ )
+
+ esconsargs+=(
+ target=$(usex tools editor template_$(usex debug{,} release))
+ dev_build=$(usex debug)
+
+ # harmless but note this bakes in --test in the final binary
+ tests=$(usex tools $(usex test))
+ )
+
+ escons "${esconsargs[@]}"
+}
+
+src_test() {
+ xdg_environment_reset
+
+ bin/godot* --headless --test || die
+}
+
+src_install() {
+ # suffix varies depending on arch/features, use wildcard to simplify
+ newbin bin/godot* godot
+
+ doman misc/dist/linux/godot.6
+ dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
+
+ if use gui; then
+ newicon icon.svg godot.svg
+ domenu misc/dist/linux/org.godotengine.Godot.desktop
+
+ insinto /usr/share/metainfo
+ doins misc/dist/linux/org.godotengine.Godot.appdata.xml
+
+ insinto /usr/share/mime/application
+ doins misc/dist/linux/org.godotengine.Godot.xml
+ fi
+
+ newbashcomp misc/dist/shell/godot.bash-completion godot
+ newfishcomp misc/dist/shell/godot.fish godot.fish
+ newzshcomp misc/dist/shell/_godot.zsh-completion _godot
+}