summaryrefslogtreecommitdiff
path: root/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild')
-rw-r--r--dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild b/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
new file mode 100644
index 000000000000..0abb1c6156a3
--- /dev/null
+++ b/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/gogo/protobuf"
+EGIT_COMMIT="fcdc5011193ff531a548e9b0301828d5a5b97fd8"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Protocol Buffers for Go with Gadgets"
+HOMEPAGE="https://github.com/gogo/protobuf"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogo || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gofast || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogofast || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogoslick || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogofaster || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/protoc-gen-{gogo,gofast,gogofast,gogofaster}
+ dodoc src/${EGO_PN}/README
+}