summaryrefslogtreecommitdiff
path: root/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild')
-rw-r--r--dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild b/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
index 98195b831952..c94cd28992d4 100644
--- a/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
+++ b/dev-haskell/alsa-core/alsa-core-0.5.0.1-r2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.1.9999
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +pkgconfig
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -17,9 +18,16 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?]
- <dev-haskell/extensible-exceptions-0.2:=[profile?]
- >=dev-lang/ghc-6.10.4:=
- media-libs/alsa-lib"
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ media-libs/alsa-lib
+"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8"
+ >=dev-haskell/cabal-1.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=pkgconfig
+}