summaryrefslogtreecommitdiff
path: root/dev-haskell/binary-tagged/binary-tagged-0.1.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/binary-tagged/binary-tagged-0.1.4.2-r1.ebuild')
-rw-r--r--dev-haskell/binary-tagged/binary-tagged-0.1.4.2-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/binary-tagged/binary-tagged-0.1.4.2-r1.ebuild b/dev-haskell/binary-tagged/binary-tagged-0.1.4.2-r1.ebuild
new file mode 100644
index 000000000000..f85e9a698e53
--- /dev/null
+++ b/dev-haskell/binary-tagged/binary-tagged-0.1.4.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Tagged binary serialisation"
+HOMEPAGE="https://github.com/phadej/binary-tagged#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?] <dev-haskell/aeson-1.1:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1.6:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/generics-sop-0.1:=[profile?]
+ >=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.16:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/sha-1.6:=[profile?] <dev-haskell/sha-1.7:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/bifunctors
+ >=dev-haskell/binary-orphans-0.1.1
+ dev-haskell/quickcheck-instances
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'generics-sop >=0.1 && <0.3' 'generics-sop >=0.1'
+}